In addition to changing the local under Control Panel|Regional and Language...
I also had to change the Registry settings:
HKEY_USERS/.DEFAULT/Control Panel/International/sShortDate
(use regedit...