www.webdeveloper.com
Results 1 to 5 of 5

Thread: please help me with this script

  1. #1
    Join Date
    Nov 2002
    Posts
    6

    Unhappy please help me with this script

    Heres the code

    <html>

    <head>
    <meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
    <meta name="generator" content="Adobe GoLive 4">
    <title>Online Portfolio</title>
    <link href="portfolio.css" rel="styleSheet" type="text/css">
    </head>

    <body bgcolor="#333333">
    <h2>
    <script language="JavaScript" type="text/javascript"><!--
    themedia = "jpg"
    thenumber = "1"

    function resetthenumber(){
    thenumber = "1"
    alert("reset the number")
    }

    function getURL(message){
    if (message=="previous"){
    thenumber = thenumber - 1
    }
    else (message=="jpg"){
    themedia = "jpg"
    }
    else (message=="gif"){
    themedia = "gif"
    }
    else (message=="mp3"){
    themedia = "mp3"
    }
    else (message=="flash"){
    themedia = "flash"
    }
    else (message=="next"){
    thenumber = thenumber + 1
    }
    parent.main.location.href = "http://www.plugwatson.com/portfolio/mainframe.cgi?number="+thenumber+"&media="+themedia
    }
    // -->
    </script>
    <table border="0" cellpadding="0" cellspacing="2" width="100%">
    <tr height="33">
    <td width="164" height="33">
    <h1>James Kennedy Watson</h1>
    <h2>Online CV / Portfolio</h2>
    </td>
    <td width="354" height="33">
    <center>
    <h4><a href="javascript:getURL('previous')">&lt; previous</a>
    - <a href="javascript:getURL('jpg')">jpg</a>
    - <a href="javascript:getURL('gif')">gif</a>
    - <a href="javascript:getURL('flash')">flash</a>
    - <a href="javascript:getURL('mp3')">mp3</a> - <a href="javascript:getURL('next')">next &gt;</a></h4>
    </center>
    </td>
    <td height="33">
    <div align="right">
    <a href="http://www.plugwatson.com/portfolio/mainframe.cgi?page=home">Home</a></div>
    </td>
    </tr>
    </table>
    </h2>
    </body>

    </html>


    this is the page its on

    http://www.plugwatson.com/portfolio/index.html

    When you click on the link it sends to the CGI by calling getURL()... but it doesn't get to call getURL... it was working a moment ago when all the equals = signs were erroneously single = signs . Since I changed them to the correct == the script stopped making it to the getURL function! Any Ideas?

  2. #2
    Join Date
    Nov 2002
    Posts
    6
    P.S. I just tried to revert the == signs back and it didn't work as before so that can't be it

    Other changes I made were the quotes in the if chain from ' to "

    Does anyone see it?

  3. #3
    Join Date
    Nov 2002
    Posts
    631
    You don't have any semicolons, but I doubt that would effect the script.

  4. #4
    Join Date
    Nov 2002
    Posts
    6
    well that suprises me! I can't believe I made that mistake, I don't get an error report and I believe semi colons are out with JS, I will do now, thanks again

  5. #5
    Join Date
    Nov 2002
    Posts
    6
    that did it but I am still having some problems Thanks I'll be back!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles