www.webdeveloper.com
Results 1 to 8 of 8

Thread: Help with my hosting!

  1. #1
    Join Date
    Oct 2005
    Posts
    252

    Help with my hosting!

    I've hosted a website in a freehosting account which supports .net 2.0 and SqlServer 2005Express and they only gave me an ftp access which i can access my website, i found that there's the "App_Data" folder which i placed my database in.
    Now here's the message i get when i try to connect to the SQL Express DB
    An attempt to attach an auto-named database for file I:\Data\Web\qsh.eu\cipherasp_015f1bdd-1338-4a35-9873-b29232b472c9\www\App_Data\cipherasp.mdf failed. A database with the same name exists, or specified file cannot be opened, or it is located on UNC share
    So, what should i do!

  2. #2
    Join Date
    Apr 2005
    Posts
    634
    does ur web host allow ur connection string to sqlexpress authenticate itself as a trust user?

    p.s: i'm looking for free host for my up coming project, got any recommendation?

  3. #3
    Join Date
    Oct 2005
    Posts
    252
    Look man, here's the hosting link, try it your self
    all i got is an ftp access to the site and this information you will find on this page, so i guess what i can do is something related to the connection string, or something else i dont know
    I didnt understand this option well i guess:
    MS SQL Server 2005 Express Edition only User Instances

  4. #4
    Join Date
    Apr 2005
    Posts
    634
    i went this this link and seems like u can access to ur db remotly. noticed you need to login, i wonder if you connection string username/password is your login?

    u may wanna send a email to ur web host

  5. #5
    Join Date
    Oct 2005
    Posts
    252
    I already tried that link for database admins, i tried to use my user name and password, also my ftp username and password but i couldnt log-in, i dont know what username and password should i use, and ofcourse i sent them but they didnt reply me

  6. #6
    Join Date
    Apr 2005
    Posts
    634
    Quote Originally Posted by Cipher
    I didnt understand this option well i guess:
    MS SQL Server 2005 Express Edition only User Instances

    check out this site and scroll all the way down to "User Instances". Looks like you may need to alter your connectionstring a little bit.

  7. #7
    Join Date
    Oct 2005
    Posts
    252
    Look here's the connection string which i use and is recommended by all the websites and help i found on the web:

    "Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\cipherasp.mdf;Integrated Security=True;User Instance=True"

  8. #8
    Join Date
    Apr 2005
    Posts
    634
    this may sound dumb....on ur file security, did u allow "everyone" to edit, modify delete on your cipherasp.mdf before u ftp to the host?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles