www.webdeveloper.com
Results 1 to 6 of 6

Thread: Image moves under

  1. #1
    Join Date
    Jun 2006
    Location
    Yorkshire, England
    Posts
    109

    Image moves under

    Hi,
    I am trying to place an image after a link (in a table), but the iage shifts down onto another line. Heres the code:
    Code:
    <TD class=menuNav><a href="mat.asp?nik=home">Home</a><img src="/images/new.gif" width="31" height="12" border="0"></TD>
    CSS:
    Code:
    .menuNav A {
    	DISPLAY: block; PADDING-LEFT: 10px; FONT-WEIGHT: normal; FONT-SIZE: 12px; BACKGROUND: #eeeeee; MARGIN: 0px 0px 1px; WIDTH: 150px; COLOR: #555555; LINE-HEIGHT: 20px; TEXT-ALIGN: left; TEXT-DECORATION: none
    }
    .menuNav A:link, A:visited {
    	COLOR: #555555; TEXT-DECORATION: none
    }
    .menuNav A:hover {
    	BACKGROUND: #6666CC;
    	font-weight: bold; COLOR: white;
    }
    Anythng obvvious? TIA

  2. #2
    Join Date
    Jul 2004
    Location
    Sendai, Japan
    Posts
    1,273

  3. #3
    Join Date
    Jun 2006
    Location
    Yorkshire, England
    Posts
    109
    Do I need to change that then? To what?
    Thanks

  4. #4
    Join Date
    Jul 2004
    Location
    Sendai, Japan
    Posts
    1,273

  5. #5
    Join Date
    Jun 2006
    Location
    Yorkshire, England
    Posts
    109
    Ok, I've removed it, now the background color (BACKGROUND: #eeeeee, only colours the text (ie the link).

    So basically the text is all #eeeeee in colour, and the image I am placing is shown as all white. Make sense?

  6. #6
    Join Date
    Jul 2004
    Location
    Sendai, Japan
    Posts
    1,273
    OK. Change it to 'float:left;'.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles