www.webdeveloper.com
Results 1 to 7 of 7

Thread: <meta http-equiv="Content-Type" content="text/html"; charset="utf-8">

  1. #1
    Join Date
    May 2007
    Posts
    138

    <meta http-equiv="Content-Type" content="text/html"; charset="utf-8">

    <meta http-equiv="Content-Type" content="text/html"; charset="utf-8">
    i made a webpage which was working perfectly on my computer , but when i uploaded my webpage , this code isnt working, so i cant change my language settings to utf-8.

    have a look pls www.futboltakip.com

    btw: I am using php and i have lots of includes on my page.
    thanks

  2. #2
    Join Date
    Aug 2004
    Location
    Ankh-Morpork
    Posts
    19,322
    As I replied in the PHP forum, you have a quoting problem there. the charset info is part of the content attribute:
    Code:
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    "Please give us a simple answer, so that we don't have to think, because if we think, we might find answers that don't fit the way we want the world to be."
    ~ Terry Pratchett in Nation

    eBookworm.us

  3. #3
    Join Date
    May 2007
    Posts
    138
    ok i changed that , but still not working , can you have a look again please
    www.futboltakip.com

  4. #4
    Join Date
    Aug 2007
    Posts
    5

    Other errors?

    NogDog's code looks fine to me. Have you ruled out other possible errors in your HTML? I'd run your code through the W3 validator (http://validator.w3.org/) to see if you have another problem with your HTML. Personally I'd get it to validate and if that doesn't fix the problem ask again.

    Out of curiosity, which web browser are you using? Have you tried this code in other web browsers, and if so, which ones?

  5. #5
    Join Date
    Jul 2008
    Posts
    2

    Encoding problem

    I'm not sure what exactly is the problem you're having with your page but in case you are referring to those eeky seemingly-random characters appearing in your page, chances are that, your page itself was not saved in unicode format. You might want to select and copy your page's codes, open a new file, paste your codes there, save and overwrite your current page then try your page again.

    If you are using Dreamweaver, make sure the Edit/Preferences/New Document/Default Encoding is set to UTF-8 before doing the procedure mentioned above.

    Hope this help.

  6. #6
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    21,654
    At least 98% of internet users' DNA is identical to that of chimpanzees

  7. #7
    Join Date
    Jul 2008
    Posts
    2

    end tag for "meta" omitted, but OMITTAG NO was specified.

    Fang check this out: http://validator.w3.org/docs/errors.html you'll find some pretty interesting stuff our masters at W3C did to make our life more adventurous.

    I did checked out the output of the validation and it seems you forgot to put a slash ("/") before the ">" on each of your lines without closing tags.

    e.g. <img src="myimage.jpg" /> <!------ notice the / before closing --->

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles