www.webdeveloper.com
Results 1 to 4 of 4

Thread: Site not working in IE

  1. #1
    Join Date
    Nov 2007
    Posts
    6

    Unhappy Site not working in IE

    I hope this is the right place to post my problem...

    but anyways, my site (http://www.versatilekyle.com) isn't working in IE. At first it takes about a billion years to load, or it just looks like its loading, I'm not exactly sure what it does, but it doesn't load the page. It blocks cookies and my site does not come up, after the cookies are allowed, the flash plays, but my buttons do not work...

    The second problem I have (although not a very big one) is a horizontal scrollbar appears on the bottom of my page though it is not wider than the page, but only in FF. The domain automatically forwards to my site that is hosted by my ISP. I'm pretty sure this problem is related to the URL forwarding, because if I type in the actual location of the site (http://home.comcast.net/~kyle_d) the bar is not present. I'm submitting a help ticket to my registrar right now, hopefully they will be able to help with this.

    Here is the HTML code for my page:

    Code:
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>versatile | kyle</title>
    
    <script language="Javascript">
    
    function gal(page) {
      OpenWin = this.open("http://home.comcast.net/~kyle_d/Album", "Kyle's Gallery","width=700,height=500,left=100,top=100,toolbar=No,location=No,scrollbars=No,status=No,resizable=No,fullscreen=no");
    }
    
    function ss(page) {
      OpenWin = this.open(page, "Soccer Star","width=420,height=300,left=100,top=100,toolbar=No,location=No,scrollbars=No,status=No,resizable=No,fullscreen=no");
    }
    
    function cdr(page) {
      OpenWin = this.open(page, "Chicken-Dragon-Rabbit Game","width=630,height=450,left=100,top=100,toolbar=No,location=No,scrollbars=No,status=No,resizable=No,fullscreen=no");
    }
    </script>
    </head>
    <body bgcolor="#000000">
    <!--url's used in the movie-->
    <!--text used in the movie-->
    <!--
    <p align="center"></p>
    -->
    <!-- saved from url=(0013)about:internet -->
    <table height="100%" width="100%">
        	<tr align="center">
    
        		<td valign="middle">
    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="775" height="680" id="main" align="middle">
    <param name="allowScriptAccess" value="sameDomain" />
    <param name="movie" value="main.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#000000" /><embed src="main.swf" quality="high" bgcolor="#000000" width="775" height="680" name="main" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
    </object>
    </td>
           </tr>
    	</table>
    </body>
    </html>
    Thanks if you can help!

  2. #2
    Join Date
    Mar 2006
    Location
    Newcastle NSW Australia
    Posts
    4,033
    The actual code to the redirection part is :
    Code:
    <html><head><title>versatile | kyle</title>
    <META NAME=\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"keywords\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\" CONTENT=\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"kyle, versatilekyle, versatile, portfolio, cool, awesome, flash, animation, movies, graphics, photoshop, GIMP, art, design, website, cartoon, drawing, amazing\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\">
    <META NAME=\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"description\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\" CONTENT=\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"Kyle\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\'s Portfolio site\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\">
    <META NAME=\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"robots\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\" CONTENT=\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"FOLLOW,INDEX\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\"></head><frameset border="0" rows="100%,*" cols="100%" frameborder="no"><frame name="TopFrame" scrolling="yes" noresize src="http://home.comcast.net/~kyle_d/index.html"><frame name="BottomFrame" scrolling="no" noresize><noframes></noframes></frameset></html>
    All those forward slashes are throwing up a heap of errors. If you did not enter those slashes when you set up the redirection, I would suggest going back, cancelling, then redoing the redirection from scratch.

  3. #3
    Join Date
    Nov 2007
    Posts
    6
    Ok well I got rid of all that and I disabled URL masking so frames went away, and that got the horizontal scroll bar disabled but I still have a big problem in IE. The buttons won't work. I assume I have to do something to the Javascript function I wrote, any ideas?

  4. #4
    Join Date
    Nov 2003
    Location
    Jerryville, Tejas
    Posts
    11,715
    All those forward slashes
    Those are backslashes. (I know; tomayto - tomahto.)
    "Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it." Brian W. Kernighan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles