www.webdeveloper.com
Results 1 to 5 of 5

Thread: Javascript Issue - Lightbox & Drop down menu code

  1. #1
    Join Date
    Dec 2008
    Posts
    7

    Angry Javascript Issue - Lightbox & Drop down menu code

    Hi,

    I'm working on www.stainlesssteelsuperstore.co.uk

    As you can see from the navigation menu at the top of the page, I have implemented a drop down menu script.

    I have used this script :

    http://www.dynamicdrive.com/dynamici...smoothmenu.htm

    It works fine on all website pages.

    However, the script encounters an error on product pages, where a lightbox feature is used to display product images.

    On product pages, neither the drop down menu or lightbox features work correctly.

    An example page is http://www.stainlesssteelsuperstore....plashback.html

    I have validated both pages and they appear fine - Therefore the issue must be JS orientated (At least that's what I think).

    Can anyone offer any advice?

    Thanks

    Will

  2. #2
    Join Date
    Dec 2008
    Posts
    7

    Smile

    44 views but no advice - Can anyone help

  3. #3
    Join Date
    May 2003
    Location
    Between Baltimore and DC
    Posts
    3,579
    JavaScript console will tell you everything you need to know:

    Behaviour is not defined
    http://www.stainlesssteelsuperstore....pts/scripts.js
    Line 441

    [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMViewCSS.getComputedStyle]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: http://ajax.googleapis.com/ajax/libs.../jquery.min.js :: anonymous :: line 22" data: no]
    http://ajax.googleapis.com/ajax/libs.../jquery.min.js
    Line 22
    Eric
    Tech Author [Ajax In Action, JavaScript: Visual Blueprint] | twitter | linkedin | http://www.pascarello.com

  4. #4
    Join Date
    Dec 2008
    Posts
    7
    OK Thanks.

    So I can see that the problem is at line 22 of that script (If I'm reading it correct?)

    I simply linked the script from the above link at Dynamic Drive and have not altered it in anyway. I presume that it's being affected by the lightbox script, which is preventing it from functioning correctly. Do you know a typical fix or proposed method I could undertake to resolve this?

    Your help is appreciated.

    Thanks

    Will

  5. #5
    Join Date
    Dec 2008
    Posts
    7
    OK Thanks.

    So I can see that the problem is at line 22 of that script (If I'm reading it correct?)

    I simply linked the script from the above link at Dynamic Drive and have not altered it in anyway. I presume that it's being affected by the lightbox script, which is preventing it from functioning correctly. Do you know a typical fix or proposed method I could undertake to resolve this?

    Your help is appreciated.

    Thanks

    Will

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles