dcsimg
www.webdeveloper.com
Results 1 to 3 of 3

Thread: Multiple FormMail.pl scripts ???

  1. #1
    Join Date
    Jan 2009
    Posts
    3

    Question Multiple FormMail.pl scripts ???

    I have two different forms on my site:
    http://www.cactusropes.com/html/contactus.html (../cig-bin/FormMail.pl)
    http://www.cactusropes.com/html/sponsorship.html (../cig-bin/form2/FormMail.pl)

    Not only do I want each form to go to a different person, I would like to have the autoreply message contain different text. So, I've created the two versions of the FormMail script above. As you can see, they reside in different folders on the server. Both are CHMOD 775.

    The contactus form works flawlessly.

    However, when I edit the FormMail.pl script in any way (specifically the autoreply text) and try to submit the form from the sponsorship page, I receive an Internal Server Error.

    If I use the FormMail.pl script from the contact page and place it in the /form2/ folder, works flawlessly.

    Something is not allowing me to edit the second script.

    For example: I only added the word "CHANGE" in the first line of the autoresponder text (CHANGE Thank you for your form submission. We appreciate your interest in Cactus Ropes - the official rope of the PRCA.) to cause the form to fail.

    I also tried having the two scripts reside in the same folder, but with different names. Same results.

    I would appreciate anyone (with more knowledge than myself - not hard) to please take a look and try and tell me what the problem is.

    Thank you in advance for your help. If you need more information, please let me know.

  2. #2
    Join Date
    Oct 2005
    Posts
    481
    What program are you using to edit the script? Are you using a plain text editor like Windows Notepad ... or an html editor like Dreamweaver, etc.? You need to use a plain text editor, as Dreamweaver (or similar) will often corrupt a script.

    Also, the script must be uploaded in ascii mode and chmod (755 probably).

    kelly

  3. #3
    Join Date
    Jan 2009
    Posts
    3
    I was using DW. I just started with a fresh download of the script and started over and waalaaa - everything worked. Thanks for your input.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles