dcsimg
www.webdeveloper.com
Results 1 to 3 of 3

Thread: if you are a flash / xml genius, I need your help!

  1. #1
    Join Date
    Feb 2009
    Posts
    5

    if you are a flash / xml genius, I need your help!

    I have an xml document, linked to a flash file.

    xml document relates to several countries of Europe, one of the nodes for each country in the xml document is a <url></url> node.

    initially all these will be empty, but over time they will get a partial url, the last part of the url only.

    how on earth do I do these two things with this node:?

    If there is no content in the node, the flash movie clip of that country is set mc.visible=false. (the background graphic creating a greyed-out effect)

    But there IS content in the node of that country, Flash sets that country movie clip to mc.visible=true
    AND extracts the data from the node, appending the nodeValue into an incomplete url on a getURL command ..

    So when there is no content, the country has no (country shaped) button to click but if there IS content in that node, it becomes visible and clickable and the url is completed, so the user can open the relevant page.

    I'm having a real problem with this and would really appreciate any pointers!

    thanks.

  2. #2
    Join Date
    Feb 2008
    Location
    NW Washington State
    Posts
    1,856
    I'm not sure you need to go the visible / invisible route. If the background image is a greyed out map and a country1_mc is correctly placed over it, What happens when there is nothing to load? ... no complete url? You get an AS error saying url not found but the grey map image still displays just fine. Then when you complete the url in your xml file, that movie clip loads and displays. The error message is just seen by the developer, not the final viewer. The only way to get rid of that error message regardless of which method you use is to not load that country1_mc, even if it is invisible.
    Just be sure your country1_mc is in a layer above the background, but that's probably what you have anyway.
    EfV

  3. #3
    Join Date
    Feb 2009
    Posts
    5
    hadn't dawned on me that .. thanks.. I'll try it. Still have some way to go before this thing works! But it's got to work THIS WEEK!

    eek!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles