www.webdeveloper.com
Results 1 to 2 of 2

Thread: a binary ascii query

  1. #1
    Join Date
    Jul 2003
    Location
    UK
    Posts
    392

    a binary ascii query

    Hi,
    I am getting an error with a Perl script:

    CGIWrap Error: Script Execution Failed
    CGIWrap encountered an error while attempting to execute this script as below. I have attempted to upload the files using an ascii ftp program and tried editing the top lines as the described but none has yet worked. Are there any other common reasons why this error should occur? I am using a windows machine and uploading to a unix machine. The files in question seem to be Perl files. Are there any other files that have to be uploaded in ascii mode?

    Error Message: Permission denied
    Error Number: 13
    This message usually indicates there is a problem with the script itself. Often this indicates either that the #! line of the script is incorrect, or the script was uploaded in binary mode instead of ascii mode. Check to make sure that the script does not have control-M's at the end of every line. That will prevent it from executing. An easy fix that takes care of this most of the time is to put '#!/.../perl --' instead of '#!/.../perl' on the first line of the script. This is typically a problem if the script was edited or uploaded from a DOS/Windows/Macintosh station to a unix based server.
    If you are not the owner of this script, please forward this error and the URL that caused it to the script owner. That is often the component in the URL right after /cgiwrap/.
    Last edited by damon2003; 11-03-2003 at 07:47 AM.

  2. #2
    Join Date
    Dec 2002
    Location
    High on life
    Posts
    10,104
    Moved to the CGI section...

    Personal website http://www.ryanbrill.com/
    Business website: http://www.infinitywebdesign.com/
    TypeSpace http://www.typespace.org/

    I reject your reality and substitute it with my own!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles