Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

Thread: FormMail with reCAPTCHA help

  1. #16
    Join Date
    Jul 2009
    To Sixtease:
    So you did substitute /your/desired/error.log to some valid filename, right? And it was a file where you are certain the web server process can write, yes?
    Yes, I did change it to a valid location and filename to error.txt, which shouldn't be a problem right? Still nothing. Sigh...

    To Winracer:
    I haven't had time to try the other formmail you've linked me there, I'm rebuilding another site, but I'll get to it once this weekend's over. Thanks.

    when you installed the original FormMail.pl script by Matt did you over write it? or did you remove and upload the reone?
    Well, I downloaded a fresh copy off Matt's website, uploaded it untouched, still 500. Changed the location of the sendmail program, changed to my domain and IP and uploaded, still 500. And this is done without adding the reCAPTCHA code and editing the form fields to match the online form.

    Even if the sendmail program location was unchanged and the domain/IP unchanged, the script would have returned an error msg and not a 500 error. That's the puzzling part.

    Thanks guys!

    I'm gonna finish up the site I'm currently busy with and jump back on this ASAP.

    If there are any alternatives to the FormMail Script that accepts reCAPTCHA code, please link them to me.

    Thanks again!
    Last edited by PulSate; 07-23-2009 at 11:27 PM.

  2. #17
    Join Date
    May 2009
    Are you uplaoding the file in ASCII or binary transfer mode. If binary, try ASCII (or text), if ASCII try binary. See your FTP applications help files for "tranfers mode" if unsure how to proceed.

  3. #18
    Join Date
    Dec 2002
    Pleasanton, CA
    use CGI::Carp(qw/warningsToBrowser fatalsToBrowser/); # Add this

    That should return your errors to the browser.
    If you still get a 500 error....

    Check that the file was uploaded in ACSII format and permission is set to 755
    If you still get a 500 error....

    Perhaps you are uploading a windows file to a unix/linux server.
    If so the file may contain a '\n\r' after the #!/usr/bin/perl, which unix/linux does not like.
    After modification, make sure you save the file in unix format before uploading.

    Just some thoughts.

  4. #19
    Join Date
    Jun 2011

    Check the file Permissions Settings

    I had the same issue and the problem was just that when I revised the formmail.pl script (using my hosting company's control panel), the permission settings changed, so I had to change them back to rwx-rx-rx.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center