www.webdeveloper.com
Results 1 to 3 of 3

Thread: Stop Autoplay

  1. #1
    Join Date
    Jan 2008
    Posts
    123

    Stop Autoplay

    All,

    I have a Flash movie posted that autoplays. I need it to stop doing that. I've tried to alter the code, but alas, nothing. Here's what I got:

    Code:
    <script language="javascript">
    	if (AC_FL_RunContent == 0) {
    		alert("This page requires AC_RunActiveContent.js.");
    	} else {
    		AC_FL_RunContent(
    			'codebase', 'http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0',
    			'width', '313',
    			'height', '245',
    			'src', 'atfs400',
    			'class', 'casePic',
    			'quality', 'high',
    			'autostart', 'false',
    			'pluginspage', 'http://www.macromedia.com/go/getflashplayer',
    			'align', 'middle',
    			'play', 'false',
    			'loop', 'false',
    			'scale', 'showall',
    			'wmode', 'window',
    			'devicefont', 'false',
    			'id', 'atfs400',
    			'bgcolor', '#000000',
    			'name', 'atfs400',
    			'menu', 'true',
    			'allowFullScreen', 'false',
    			'allowScriptAccess','sameDomain',
    			'movie', 'atfs400',
    			'salign', ''
    			); //end AC code
    	}
    </script>
    <noscript>
    	<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="313" height="245" id="atfs400" align="middle">
    	<param name="allowScriptAccess" value="sameDomain" />
    	<param name="allowFullScreen" value="false" />
    	<param name="movie" value="atfs400.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#000000" />	<embed src="atfs400.swf" autostart="false" quality="high" bgcolor="#000000" width="313" height="245" name="atfs400" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
    	</object>
    
    </noscript>
    Am I doing something wrong?

    thanks,

    --thesprucegoose

  2. #2
    Join Date
    Aug 2009
    Posts
    13
    I didnt see anything wrong, try publishing the movie with autostart off.

  3. #3
    Join Date
    May 2009
    Location
    Rochester, NY
    Posts
    364
    I think you need to reexport your movie after changing the settings in the file itself. I've had this problem before, and I fixed it by doing that.

    Also, I think this belongs in Multimedia. You might get more responses.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles