www.webdeveloper.com
Results 1 to 2 of 2

Thread: sendmail not sending some mails to yahoo,rediff etc

  1. #1
    Join Date
    Oct 2008
    Posts
    9

    sendmail not sending some mails to yahoo,rediff etc

    Hi, this is sasidhar.
    we are getting problems with sendmail.
    we have a site, when user registers we are sending a confirmation mail to user.
    The problem is some times it is not sending mails to users.
    The user accounts are valid.

    This is what I am getting reply to my mail
    1)
    **********************************************
    ** THIS IS A WARNING MESSAGE ONLY **
    ** YOU DO NOT NEED TO RESEND YOUR MESSAGE **
    **********************************************

    The original message was received at Fri, 9 Oct 2009 00:08:11 -0400
    from localhost.localdomain [127.0.0.1]

    ----- Transcript of session follows -----
    <xxxx@rediffmail.com>... Deferred
    Warning: message still undelivered after 4 hours
    Will keep trying until message is 5 days old

    Final-Recipient: RFC822; xxxxx@rediffmail.com
    Action: delayed
    Status: 4.2.0
    Last-Attempt-Date: Fri, 9 Oct 2009 04:27:36 -0400
    Will-Retry-Until: Wed, 14 Oct 2009 00:08:11 -0400

    ---------------------------------------------------------------------------------------------------------------------------

    After 5 days also it is there in mqueue.

    For gmail it is working fine, yahoo some times it is working some times it is not.
    In gmail it is going to inbox.
    In yahoo it is going to spam.

    In rediff for every 10 mails 6 to 7 are there in mqueue.

    With this problem every 100 mails on an average we are loosing 20 to 30 mails there in mqueue.

    Please give respond to this topic.

    Thanks,
    sasidhar.

  2. #2
    Join Date
    Mar 2004
    Posts
    3,056
    You're listed on abuse.rfc-ignorant.org. You should see what you can do about getting removed from this list. You're also listed on APEWS, too, but there's not much you can do about that and there's not much need to do anything about it either. APEWS is not used by most filters because it blacklists about half of the planet.

    Strange thing is, though, that I checked your domain about 30 minutes ago and it said you weren't listed on abuse.rfc-ignorant.org, but that you didn't have an MX record either. Could it just be coincedence that I checked just as some change was being made, or might something be wrong with your DNS entries?

    If you're wondering, I used http://www.blacklistalert.org/ to check your domain name. It's handy because it does lots of checks all at once for you. Rather than having to do all of them individually. I'd recommend regular monitoring of the output from checking your domain name in blacklistalert.org (and maybe a few other lists) to see if any more inconsistencies arise.

    Other possibilities might be that your application that generates the mails is on a host that is blacklisted by your mail server, or your application that generates mails is generating mails in a way that the recipient domain doesn't like. I remember I kept getting rejected by a few domains when I was building the first parts of a mail generator because I hadn't done something quite right with the headers.

    I'll have a look back through my old code to see if anything jogs my memory.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles