dcsimg
www.webdeveloper.com
Results 1 to 4 of 4

Thread: Mac xampp database issue - "failed opening required"

Hybrid View

  1. #1
    Join Date
    Feb 2008
    Location
    Edmonton, AB
    Posts
    34

    Angry Mac xampp database issue - "failed opening required"

    Hey All,

    I have xampp 1.7.2a installed on my MacBook Pro 10.5.8. I run all my local websites from my "Sites" folder.

    Up until now I have had no issues running php scripts. I setup a database using MyPHPAdmin which went fine. When I try and view some supplied files I get the following error: (please note I am a student and the files were supplied by an instructor - they work for everyone else, the only difference is i work on my personal mac and the rest work on a pc...anyways here is the error...)

    Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

    Fatal error: Unknown: Failed opening required '/Applications/XAMPP/xamppfiles/htdocs/simpsons/list.php' (include_path='.:/Applications/xampp/xamppfiles/lib/php:/Applications/xampp/xamppfiles/lib/php/pear') in Unknown on line 0

    I've played around with the include path after soem research but nothign seems to be working. I have also tried running the files from the htdocs folder in my xampp folder to the same result.

    Please please please help.....

  2. #2
    Join Date
    Sep 2008
    Location
    Mexico
    Posts
    786
    Unknown on line 0
    confuses me.
    Does this happen on all PEAR requests? Do you have a PEAR repository installed locally? or are you trying to access it via the internet?

  3. #3
    Join Date
    Feb 2008
    Location
    Edmonton, AB
    Posts
    34
    This is all local. All I have doen is installed the latest version of xampp. I won't lie to you. I don't know what pear even is lol. I'm a front end designer and developer but just getting my feet wet with some basic database and php stuff.

    Cheers,
    G

  4. #4
    Join Date
    Sep 2008
    Location
    Mexico
    Posts
    786
    That being the case, then PEAR probably was not enabled when you installed xampp.
    Here is a "how to" that might help.
    I have this stuff because I recommend xampp to my students.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles