Results 1 to 10 of 10

Thread: chmod 777 yet still no public access or file not found?

  1. #1
    Join Date
    Nov 2009

    Unhappy chmod 777 yet still no public access or file not found?

    Hi all,

    I've searched for this problem in recent threads, and as I couldn't find it in any of them, I decided to start this thread. I am a magnet for weird problems.

    There's this groupware webapplication that I want to test, and for that, I put it on my own personal domain using FileZilla. From there on, I had to install the application on my domain, which in part entails making some directories outside of the document root with 777 permissions. Each time I do that, and in whatever directory I put the directories, the application install can't seem to find them.

    What's more striking, is what happened after I changed the permissions of all files and directories of said web application to 777, just as a test. After that, my browser rewarded me with a "The requested URL /works/trunk-clean/www/install was not found on this server." message whenever I entered some directory or file of the web application in my browser.

    I'll try to locally change the permissions of the directory before uploading it again and see what happens then, but still... this is weird, isn't it? Any ideas?

    There's this other thing that may be related to the above problem. If I tell FileZilla to delete the entire directory of the web application, it says repeatedly and for every subdirectory, among others, "550 Remove directory operation failed," and the directories remain on the FileZilla GUI. What's up with that?

    [EDIT :] Well I did that last option, but I get similar results. The only difference is, when I copy the directories into the web application directory, and then do chmod 777 on them, I get a 403 error when I try to access them by typing the URL into the browser. So after FileZilla does a 777 on the directories (and the FileZilla GUI's directory listing says that went well), my browser greets me by saying I don't have enough permissions to access that directory "on this server". What?

    Can anyone please help me on this one? I'm afraid it may take days before I can make any progress with my work because of this...


  2. #2
    Join Date
    Jun 2009
    You will have to palce the files and folders inside the public_html folder which you would like to access globally. Moreover for the error message please make sure that have assigned the appropriate ownership to the files and folders. The ownership to the folders and files should be user:user not nobody:nobody or user:nobody.

    If the ownership is user:user then kindly check the error logs for the exact error message as there are many reasons for the 403 error. You can check the error logs from /usr/local/apache/logs/error_log.

  3. #3
    Join Date
    Nov 2009
    Thanks for your reply. I'm using FileZilla and want to access all the files and directories on a separate server of my webhoster. I'll see how I can change ownership with FileZilla and check the error logs there.

  4. #4
    Join Date
    Jun 2009
    You cannot check the ownership and error logs from the filezilla. However, you will have to login to your linux server through SSH and then you can check the error logs and the ownership of the folder.

  5. #5
    Join Date
    Nov 2009
    How do I do that?

  6. #6
    Join Date
    Sep 2008
    how and what you do it will depend on what kind of server you have and what options have been allowed to you by the web host.
    • what kind of server?
    • what kind of control interface (cPanel, etc)?
    • is your access to SSH enabled?

    Have you asked your host about the problem?
    And as webhostingdi nothing outside of the web-root folder is accessible via http.

    What application are you attempting to install???
    ...but stupidity is terminal.

  7. #7
    Join Date
    Jun 2009
    Quote Originally Posted by Wilmar View Post
    How do I do that?
    Is your domain is hosted on Shared Servers? If yes, then may I know which control panel are you using and also do you have an root access to the SSH. If you do not have an root access then you will have to contact your hosting provider service.

  8. #8
    Join Date
    Nov 2009
    Right now, I am working on collecting the information you all asked for. I will get back to this later.

  9. #9
    Join Date
    Nov 2009
    Well I got the info you asked for from my web hoster:
    1) Just Linux-based servers.
    2) Control interface is a support page.
    3) No SSH access.
    4) Currently no root access.

    Does that answer your questions?

  10. #10
    Join Date
    Sep 2008
    Then you have your answer.... you cannot do what you are trying to do with this app.
    There are dozens of good groupware applications floating around. Look for a different one.
    ...but stupidity is terminal.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center



X vBulletin 4.2.2 Debug Information

  • Page Generation 0.10391 seconds
  • Memory Usage 2,935KB
  • Queries Executed 13 (?)
More Information
Template Usage (33):
  • (1)ad_footer_end
  • (1)ad_footer_start
  • (1)ad_global_above_footer
  • (1)ad_global_below_navbar
  • (1)ad_global_header1
  • (1)ad_global_header2
  • (1)ad_navbar_below
  • (1)ad_showthread_firstpost_sig
  • (1)ad_showthread_firstpost_start
  • (1)ad_thread_first_post_content
  • (1)ad_thread_last_post_content
  • (1)bbcode_quote
  • (1)footer
  • (1)forumjump
  • (1)forumrules
  • (1)gobutton
  • (1)header
  • (1)headinclude
  • (1)headinclude_bottom
  • (10)memberaction_dropdown
  • (1)navbar
  • (4)navbar_link
  • (1)navbar_moderation
  • (1)navbar_noticebit
  • (1)navbar_tabs
  • (2)option
  • (10)postbit
  • (10)postbit_onlinestatus
  • (10)postbit_wrapper
  • (1)spacer_close
  • (1)spacer_open
  • (1)tagbit_wrapper 

Phrase Groups Available (6):
  • global
  • inlinemod
  • postbit
  • posting
  • reputationlevel
  • showthread
Included Files (26):
  • ./showthread.php
  • ./global.php
  • ./includes/class_bootstrap.php
  • ./includes/init.php
  • ./includes/class_core.php
  • ./includes/config.php
  • ./includes/functions.php
  • ./includes/functions_navigation.php
  • ./includes/class_friendly_url.php
  • ./includes/class_hook.php
  • ./includes/class_bootstrap_framework.php
  • ./vb/vb.php
  • ./vb/phrase.php
  • ./includes/functions_facebook.php
  • ./includes/functions_calendar.php
  • ./includes/functions_bigthree.php
  • ./includes/class_postbit.php
  • ./includes/class_bbcode.php
  • ./includes/functions_reputation.php
  • ./includes/functions_notice.php
  • ./packages/vbattach/attach.php
  • ./vb/types.php
  • ./vb/cache.php
  • ./vb/cache/db.php
  • ./vb/cache/observer/db.php
  • ./vb/cache/observer.php 

Hooks Called (70):
  • init_startup
  • friendlyurl_resolve_class
  • init_startup_session_setup_start
  • database_pre_fetch_array
  • database_post_fetch_array
  • init_startup_session_setup_complete
  • global_bootstrap_init_start
  • global_bootstrap_init_complete
  • cache_permissions
  • fetch_threadinfo_query
  • fetch_threadinfo
  • fetch_foruminfo
  • load_show_variables
  • load_forum_show_variables
  • global_state_check
  • global_bootstrap_complete
  • global_start
  • style_fetch
  • global_setup_complete
  • showthread_start
  • showthread_getinfo
  • strip_bbcode
  • friendlyurl_clean_fragment
  • friendlyurl_geturl
  • forumjump
  • cache_templates
  • cache_templates_process
  • template_register_var
  • template_render_output
  • fetch_template_start
  • fetch_template_complete
  • parse_templates
  • fetch_musername
  • notices_check_start
  • notices_noticebit
  • process_templates_complete
  • friendlyurl_redirect_canonical
  • showthread_post_start
  • showthread_query_postids
  • showthread_query
  • bbcode_fetch_tags
  • bbcode_create
  • showthread_postbit_create
  • postbit_factory
  • postbit_display_start
  • postbit_imicons
  • bbcode_parse_start
  • bbcode_parse_complete_precache
  • bbcode_parse_complete
  • postbit_display_complete
  • memberaction_dropdown
  • tag_fetchbit_complete
  • forumrules
  • navbits
  • navbits_complete
  • build_navigation_data
  • build_navigation_array
  • check_navigation_permission
  • process_navigation_links_start
  • process_navigation_links_complete
  • set_navigation_menu_element
  • build_navigation_menudata
  • build_navigation_listdata
  • build_navigation_list
  • set_navigation_tab_main
  • set_navigation_tab_fallback
  • navigation_tab_complete
  • fb_like_button
  • showthread_complete
  • page_templates