www.webdeveloper.com
Results 1 to 3 of 3

Thread: help please....noob

  1. #1
    Join Date
    Dec 2009
    Posts
    1

    help please....noob

    hi, i have created a really basic site (well its just a welcome page really, i will complete the site of the next few months)
    i have bought my domain name and pointed the dns records to the ip of the webhost server. (i think i have done this right)
    when i browse to w w w.domain.com i get an error page
    when i browse to h t t p://domain.com i get a list of the files that i have published to the site, i can see my default.html page/file and when i click it i see the page that i want to display.
    1 - why does it not just show the site when i go to w w w.domain.com ?
    2 - why does it show me the file list when i go to h t t p://domain.com ?
    can anyone tell me what i've done wrong????
    any help would be great
    thanks
    ian

  2. #2
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    21,654
    1) Contact you host; domain setup is incorrect

    2) index.html is the usual file to be initially displayed. If you want to use default.html, then add/change this in the .htaccess file
    Code:
    DirectoryIndex default.html
    Prevent file listing

  3. #3
    Join Date
    Jun 2009
    Posts
    127
    Quote Originally Posted by daddymcbeal View Post
    hi, i have created a really basic site (well its just a welcome page really, i will complete the site of the next few months)
    i have bought my domain name and pointed the dns records to the ip of the webhost server. (i think i have done this right)
    when i browse to w w w.domain.com i get an error page
    when i browse to h t t p://domain.com i get a list of the files that i have published to the site, i can see my default.html page/file and when i click it i see the page that i want to display.
    1 - why does it not just show the site when i go to w w w.domain.com ?
    2 - why does it show me the file list when i go to h t t p://domain.com ?
    can anyone tell me what i've done wrong????
    any help would be great
    thanks
    ian
    1 - why does it not just show the site when i go to w w w.domain.com ?

    Please make sure that CNAME record for www is added in your DNS Zone editor. If it is not added you will have to add it in your DNS zone editor which may take 2-3 hours to propagate after adding it.

    2 - why does it show me the file list when i go to h t t p://domain.com ?

    Make sure that you have uploaded all your contents inside the root directory and also you have set the directorylist default.html as the higher priority. If the directory list is empty then you will have to create it manually as mentioned by Fang.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles