www.webdeveloper.com
Page 1 of 4 123 ... LastLast
Results 1 to 15 of 58

Thread: main.php: missing parameter: is_superuser

  1. #1
    Join Date
    Feb 2010
    Posts
    32

    main.php: missing parameter: is_superuser

    hello,
    since i have updated my Firefox to ver. 3.6
    my PMA had showed the error >> main.php: missing parameter: is_superuser
    as soon after i have entered my password and gotten in (please notice this is on my local server -Apache)
    any way the problem doesn't appear to happen in IE8

    i tried upgrading PMA to version 3.2.5 but nothing changed ( i hadn't changed back to the older version)
    PMA sent me to FAQ 2.8 but i didn't understand a thing.

    please help me fix this problem. i hate IE

  2. #2
    Join Date
    Jun 2009
    Posts
    127
    Please make sure that you have set the appropriate path in your php.ini file on the below mentioned location:

    session.save_path=/serverphp/session

  3. #3
    Join Date
    Jan 2009
    Posts
    3,346
    @OP: Have you tried any of these steps?
    Here are a few points to check:

    * In config.inc.php, try to leave the $cfg['PmaAbsoluteUri'] directive empty. See also FAQ 4.7.
    * Maybe you have a broken PHP installation or you need to upgrade your Zend Optimizer. See http://bugs.php.net/bug.php?id=31134.
    * If you are using Hardened PHP with the ini directive varfilter.max_request_variables set to the default (200) or another low value, you could get this error if your table has a high number of columns. Adjust this setting accordingly. (Thanks to Klaus Dorninger for the hint).
    * In the php.ini directive arg_separator.input, a value of ";" will cause this error. Replace it with "&;".
    * If you are using Hardened-PHP, you might want to increase request limits.
    * The directory specified in the php.ini directive session.save_path does not exist or is read-only.
    Additionally, upgrading FF should have nothing to do with the server-side config files...are you sure you didn't change/upgrade anything else?

  4. #4
    Join Date
    Feb 2010
    Posts
    32
    thewebhostingdi, i didnt understand what you suggested..im kinda new to all of this..

    besides i keep seeing "zend optimizer" what is it?

    also i just realized that windows opens a crash message on Apache sometimes when i try logging in to PMA. can that have any thing to do with it??

  5. #5
    Join Date
    Jan 2009
    Posts
    3,346
    Did you use a precompiled installer for you apache/mysql/php/pma stack (i.e. wamp, etc) or did you install each manually?

  6. #6
    Join Date
    Feb 2010
    Posts
    32
    manually

  7. #7
    Join Date
    Jan 2009
    Posts
    3,346
    Did you edit the distribution php.ini file at all? What does the session.save_path look like?

  8. #8
    Join Date
    Feb 2010
    Posts
    32
    ; session.save_path = "/tmp"

  9. #9
    Join Date
    Jan 2009
    Posts
    3,346
    Code:
    session.save_path = "c:\temp"
    Then make sure that directory exists.

  10. #10
    Join Date
    Feb 2010
    Posts
    32
    it did help however i got a windows crash message again:
    ---------------

    Error signature:
    szAppName : Apache.exe szAppVer : 2.0.52.0 szModName : php5ts.dll
    szModVer : 5.2.9.9 offset : 0009c8bd

    included filse:
    C:\DOCUME~1\Gidon_2\LOCALS~1\Temp\WER68b5.dir00\Apache.exe.mdmp
    C:\DOCUME~1\Gidon_2\LOCALS~1\Temp\WER68b5.dir00\appcompat.txt

    ------------

    should this concern me?

  11. #11
    Join Date
    Jan 2009
    Posts
    3,346
    I would uninstall and start over. Install Apache first, then PHP. If you use the windows binary installer for PHP it will automatically append the appropriate content to your apache .conf. Once that is completed download the zip file for PHP and unzip into the installed php folder to enable any missing modules.


    I was confused by your first post stating that you were only getting errors in FF and that IE was fine and that the errors only started when you upgraded your FF version. None of those statements had anything to do with the problem as they would all be client-side problems and you have a server configuration problem. Did you have this server working with PMA before or have you just started to use PMA?

  12. #12
    Join Date
    Feb 2010
    Posts
    32
    i had it working with PMA before. it also confused me. can it be that IE has some special features to deal with it?

  13. #13
    Join Date
    Jan 2009
    Posts
    3,346
    Your issue is a server configuration issue and client-side browsers will have no bearing on that. It is possible that the error message is being hidden in IE8 somehow but IE cannot fix an issue on the server. Did you try reinstalling Apache and PHP?

  14. #14
    Join Date
    Feb 2010
    Posts
    32
    not yet.. but it is working fine even though the error message.. so I'm just gonna wait and see how it turns out.

    thank you for all your help..it is much easier to work now.

  15. #15
    Join Date
    Jan 2009
    Posts
    3,346
    I would reinstall PHP. It seems like the apache module in your current install seems corrupted. You can just download the zip and overwrite your PHP install folder. Make sure to stop Apache before you overwrite the .dll so it won't stumble on it. Let me know if that fixes your issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles