www.webdeveloper.com
Results 1 to 6 of 6

Thread: Media Player Control not showing In FireFox

  1. #1
    Join Date
    Feb 2010
    Posts
    5

    Post Media Player Control not showing In FireFox

    I am using a media player control and passing the movie url. It works fine in IE open the file and play it.In Firefox the player is not visible but when check using FireBug the object tag is inside the page.

  2. #2
    Join Date
    Feb 2010
    Location
    Amsterdam
    Posts
    174
    erm this has nothing to do with .NET...

    stupid question but did you install the firefox windows media player plugin?

    (http://port25.technet.com/pages/wind...-download.aspx)

  3. #3
    Join Date
    Feb 2010
    Posts
    5

    Smile Media Player Control not showing In FireFox

    Hi,
    I have installed the plugin for the firefox.But still I am facing the problem.

    Code:
    <OBJECT width="476px" height="354px" CLASSID="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6" VIEWASTEXT>
    <PARAM name="autoStart" value="True">
    <PARAM name="URL" value="C:\Mediaplayer\mediaplayer\mediaplayer\Beethoven.wma">
    <PARAM name="enabled" value="True">
    <PARAM name="balance" value="0">
    <PARAM name="currentPosition" value="0">
    
    <PARAM name="enableContextMenu" value="True">
    <PARAM name="fullScreen" value="False">
    <PARAM name="mute" value="False">
    <PARAM name="playCount" value="1">
    <PARAM name="rate" value="1">
    <PARAM name="stretchToFit" value="False">
    <PARAM name="uiMode" value="mini">
    </OBJECT>
    above is the code generated by my control.

  4. #4
    Join Date
    Feb 2010
    Location
    Amsterdam
    Posts
    174
    your linking to a file on your hard drive, i would point to the http location:

    <PARAM name="URL" value="C:\Mediaplayer\mediaplayer\mediaplayer\Beethoven.wma">

  5. #5
    Join Date
    Feb 2010
    Posts
    5

    Smile Firefox window media player problem

    I am using the media file realtive to the application and I am passing the file as simple name as Beethoven.wma

  6. #6
    Join Date
    Feb 2008
    Location
    NW Washington State
    Posts
    1,856
    You may need to declare an application type and/use the old <embed> tag to get it to work in FF.
    Code:
    <OBJECT ID="MediaPlayer" WIDTH="192" HEIGHT="190" CLASSID="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
    STANDBY="Loading Windows Media Player components..." TYPE="application/x-oleobject">
    <PARAM NAME="FileName" VALUE="videofilename.wmv">
    <PARAM name="autostart" VALUE="false">
    <PARAM name="ShowControls" VALUE="true">
    <param name="ShowStatusBar" value="false">
    <PARAM name="ShowDisplay" VALUE="false">
    <EMBED TYPE="application/x-mplayer2" SRC="videofilename.wmv" NAME="MediaPlayer"
    WIDTH="192" HEIGHT="190" ShowControls="1" ShowStatusBar="0" ShowDisplay="0" autostart="0"> </EMBED>
    </OBJECT>
    Best wishes,
    Eye for Video
    www.cidigitalmedia.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles