dcsimg
www.webdeveloper.com
Results 1 to 8 of 8

Thread: page loading very slow for some - even lock-ups

  1. #1
    Join Date
    Jan 2007
    Posts
    24

    page loading very slow for some - even lock-ups

    Hi all & thanks in advance for taking a look into this - i can't figure it out but suspect the video or a java script on page is conflicting with something

    http://hbrestaurants.com/taste/index.html

    loads slow for some and locks up when you navigate back to home for some - even did it to me once... can't remember what browser i was on at the time.

    any ideas or suggestions?

    thanks!

    Cliff

  2. #2
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    21,654
    Analyze the page, cut back on the images.

  3. #3
    Join Date
    Jan 2007
    Posts
    24

    images can be optimized but that aint it

    try to link back to homepage after going to a sub page like: http://hbrestaurants.com/taste/taste_media.html

    that's when you really see the bog down... after going to another page and then back to the homepage...

    thanks!

    Cliff

  4. #4
    Join Date
    Jan 2007
    Posts
    24
    maybe because it links back to index.html and should be using the full link address (since it's in a sub folder)??

    thx!

  5. #5
    Join Date
    Apr 2003
    Location
    Netherlands
    Posts
    21,654
    No difference.

  6. #6
    Join Date
    Mar 2010
    Posts
    10
    Hi

    I have had this problem & it was a large image in the background.

  7. #7
    Join Date
    Jan 2007
    Posts
    24
    hmmm... but isn't it odd that when you go to a sub-page and then back to home/index that's usually when it locks up? if it was an image you'd already have it cached from being on the home page before...

    i'm now thinking it has something to do with a script on page (the countdown clock) because i see an error in IE saying issue in that area... i'll try to pull it and re-post a test page to see if that's it

    any other thoughts? thx!

  8. #8
    Join Date
    Jan 2007
    Posts
    24

    Exclamation

    UPDATE

    i created a new test version of this homepage removing a javascript date countdown: http://www.hbrestaurants.com/taste/index_noscript.html

    and if you click the link to MEDIA (test page with new home link) then click back HOME button then it loads ok...

    (if you go to current homepage: http://www.hbrestaurants.com/taste/index.html and click any button and then back HOME you'll see the lag)

    it seems to only do this on IE not firefox (and on IE7 on one of my systems).

    anyhow thanks Fang & Kathyholder for your thoughts. - i just need to talk 'council' into dropping this countdown script... this should fun...
    PS - avoid projects run by a 'council'

    thanks!
    Cliff

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles