www.webdeveloper.com
Page 1 of 2 12 LastLast
Results 1 to 15 of 22

Thread: IIS will not run ASP from LocalHost - HELP

  1. #1
    Join Date
    Nov 2004
    Location
    Huntington WV
    Posts
    8

    IIS will not run ASP from LocalHost - HELP

    I have a new ASP project that I need to desperately test on my Windows 2000 machine before posing to my Hosting Company. I am having problems getting the ASP pages to run from LocalHost. I will attempt to give as much information of what I have done to try to correct this without success.

    First my setup. Windows 2000 Professional with Service Pack 2 installed. IIS is installed. I have turned off the firewall just in case that was a problem as the laptop is operating as a stand alone and not on a network at this time. I also have VB6 with Service Pack 6 installed. I will explain later why that my be pertinent.

    The error that I am getting is:
    The Page Cannot Be Displayed. with a HTTP 500 error. This occurs every time I try to access a ASP page. HTML works fine from LocalHost.

    IIS Setup Information:
    Server Extension set to VBScript
    Applications Settings ---> Execute Permissions: Scripts and Executables.
    .ASP Extensions set to GET, HEAD, POST, TRACE – Script Engine Checked.
    wwwroot ---> Internet Guest and Launch IIS Process have Full Control.

    I am getting the following error in the Event Viewer:
    Source: W3SVC
    Description: The server failed to load application ‘/LM/W3SVC/1/ROOT’. The error was ‘General access denied error

    I read on the web that VB6 Service Pack 6 will break IIS and that it is caused by permissions on a DLL File. I made the suggested correction and it did not resolve the problem. I have un-installed and re-installed IIS.

    On IE 5.5 I have set the Internet Options under LAN Settings to Bypass proxy server for local addresses.

    My test page is Microsoft Default http://localhost/localhost.asp

    Keep in mind that HTML pages are working so I know that IIS is running.

    Any suggestions would be great. I have been fighting this for 3 days and can not seem to find any help from anyone. You would think that IIS would work out of the box. It is also interesting that by default IIS sets up to run JAVA instead of ASP or VBScripts.

    Thank you
    Mike

  2. #2
    Join Date
    Feb 2003
    Posts
    2,745
    Go to the IIS Management console.
    Right-click the web site.
    Click properties.
    Click the Directory Security tab
    In the Anonymous Acess panel, click Edit
    Make sure Anonymous access is checked and click Edit
    Un-check "Allow IIS to control password"
    Type in the username and password you log on to the box with.
    Confirm the password and click ok.

    This ought to fix it for ya.

  3. #3
    Join Date
    Nov 2004
    Location
    Huntington WV
    Posts
    8

    Thanks Russell but no go

    Thank you Russell for the suggestion. But no success. I restarted the workstation after I make your suggestion just to be sure. Any other ideas?

    Mike

  4. #4
    Join Date
    Feb 2003
    Posts
    2,745
    Are you administrator on the pc?

  5. #5
    Join Date
    Nov 2004
    Location
    Huntington WV
    Posts
    8

    I am the Administrator

    Russell. I am the Administrator of the pc. I even use the logon Administrator account with the password of Password. I know, not very secure but all my developement work is stored on a USB key so I keep security at a minimum on my LAPTOP. Just for reasons like this. I also have given full access rights to the WWWROOT and sub folders to the IIS accounts. Love the suggestions. Any more? Thanks, Mike

  6. #6
    Join Date
    Feb 2003
    Posts
    2,745
    You don't need any server extensions for the site to run, unless you are remotely publishing (front page or interdev for example) which have the nasty habit of changing the permissions on the actual directory. Just to be sure, check the permissions on the root directory of your site. Next, back in the IIS mmc, under the Home Directory tab, I'd give scripts and executables permissions, Medium application protection (pooled). Click Configuration and make sure that cache isapi applicatons is checked. Under app options, make sure defualt language is VBScript. Turn off Server side debugging, if its enabled.

    does it fail on ALL asp pages, or only some?

    Also, I've never had any issues running IIS and VB6 on the same box.

  7. #7
    Join Date
    Feb 2003
    Posts
    2,745
    Another thought: make sure logging is enabled. What error are you getting in the IIS logs (different from event viewer)? What error do you see in the browser. In IE make sure "Show Friendly HTTP Error Messages" is NOT checked in the advanced settings under the Tools | Options menu.

  8. #8
    Join Date
    Nov 2004
    Location
    Huntington WV
    Posts
    8

    Thank you but still no go.

    Russell, Thank you for your time. I have been checking everything that you listed above. I did find a change, but it did not correct the problem. I turned off Friendly URL and her is the message that I get. "Server Application Error" The server has encountered an error while loading an application during the processing of your request. Please refer to the event log for more detail information. Please contact the server administrator for assistance.

    Here is the event logs that gets generated.
    Source W3SVC
    Description: The server failed to load application '/LM/W3SVC/1/ROOT' The error was 'General access denied error'

    The other event log that was generated was.
    'The server was unable to register teh administration tool discovery information. The administration tool may not be able to see the server. The data is the rror code.

    Boy, you have to love the people who write there error event log text. lol.

    Russell, I can not tell you how much I apprecate your time. This is very important for me to get this running this weekend so I can start code testing.

    --- All ASP pages are generating the same error.

    Mike

  9. #9
    Join Date
    Feb 2003
    Posts
    2,745
    What version of w3svc.dll do you have? Mine is 5.0.2195.6700. Check the permissions on the dll in win explorer.

    How many web sites are set up on your machine?

    Do you have port 80 and "All Unassigned" as the IP Address and TCP port in the Web Site tab of the IIS MMC?

    Maybe try creating a new one, with permissions as I described -- especially in my 1st post, and copy an asp file to it, see if that one works.

    Try using your IP address instead of localhost (though this really shouldn't matter). To see IP, start, run, cmd -- type ipconfig.

  10. #10
    Join Date
    Nov 2004
    Location
    Huntington WV
    Posts
    8

    More info

    My w3svc.dll version is 5.0.2195.2966 so it is a little different from yours.

    I do have port 80 and All Unassigned. There is no IP address because the laptop is not connected to a network.

    I get a strange feeling that it has something to do with permissions on a DLL file that is located in the WINNT/SYSTEM32 folder. Do not ask me why but I just get this from other threads that I have read. I also think that it my have something to do with VB6 but I have nothing to support this theory. But the bottom line is I do not think I am going to resolve it by this weekend so I will just work on HTML and leave ASP till Monday.

    Thanks for your help and suggestions. The mystery continues.

    Have a good weekend.

    Mike

  11. #11
    Join Date
    Feb 2003
    Posts
    2,745
    Maybe you can post your asp files to the hosting company in an unpublished subdirectory, so that you can test your asp.

    If I think of anything else, i'll post back.

  12. #12
    Join Date
    Nov 2004
    Location
    Huntington WV
    Posts
    8

    Thanks for all your help Russell

    I have a number of options for testing my app. At work I have a Intranet server that I can test the code on. I also could do as you suggest and hide it on my Host Site. But I do most of my coding with my laptop and it moves with me all the time. So when I get inspired I can just go to work, I know you know what I mean. I do my best work at Starbucks in the evenings. I write shareware programs and this is where I do my work. Nice to get paid for hanging out at Starbucks drinking Chi Tea.

    I took on a large web site development project with some tight deadlines. So I really wanted to get started this weekend. But it was not to be.

    You take care. If I find the answer, and I will. I will post it. I never give up.

    Thanks,
    Mike

  13. #13
    Join Date
    Jun 2003
    Location
    Indiana, USA
    Posts
    1,138
    are you sure your asp pages are corectly coded?

  14. #14
    Join Date
    Feb 2003
    Posts
    2,745
    Mike, while I suspect that your search has turned up these KB articles already, I thought I'd put 'em up here for ya just in case. Let me know how it turns out.

    russell

    Check out the first one especially.

    http://support.microsoft.com/default...b;en-us;309051
    http://support.microsoft.com/default...b;EN-US;297519
    http://support.microsoft.com/kb/297989/EN-US/

  15. #15
    Join Date
    Nov 2004
    Location
    Huntington WV
    Posts
    8

    Problem Resolved !!!

    Russell,

    Thank you for all your help. I started searching Google for W3SVC + 36 + 'General access denied error' because this was what was in the error log every time I tried running an ASP page. Here is what I found that worked......
    Thanks for your replys, the problem was with my permission. article below may help others with permission problems

    Mark

    -----------------------------------------------------------------------
    The information in this article applies to:

    - Microsoft Internet Information Services version 5.0
    -----------------------------------------------------------------------

    SYMPTOMS
    ========

    This article lists the minimum NTFS access permissions needed for an IIS
    5.0 Web
    Site. When IIS is installed, it should already have the proper NTFS
    access
    permissions for the Default Web Site and Default FTP Site. There are a
    number of
    different directories that need the correct NTFS permissions so
    incorrect
    settings on any one of these can cause some of the following errors:

    Displayed in Web Browser:

    You are not authorized to view this page
    You do not have permission to view this directory or page using the
    credentials you supplied.

    HTTP 401.3 - Access denied by ACL on resource Internet Information
    Services

    --OR--

    Displayed in Web Browser:

    Server Application Error
    The server has encountered an error while loading an application
    during the
    processing of your request. Please refer to the event log for more
    detailed
    information. Please contact the server administrator for assistance.

    Displayed in System Log:

    Event Type: Warning
    Event Source: W3SVC
    Event Category: None
    Event ID: 36
    Date: 3/5/2001
    Time: 9:59:40 AM
    User: N/A
    Computer: MACHINE-NAME
    Description:
    The server failed to load application '/LM/W3SVC/5/Root'. The error
    was
    'General access denied error'.
    For additional information specific to this message please visit the
    Microsoft
    Online Support site located at:
    http://www.microsoft.com/contentredirect.asp.

    Event Type: Error
    Event Source: DCOM
    Event Category: None
    Event ID: 10001
    Date: 3/5/2001
    Time: 9:59:40 AM
    User: NT AUTHORITY\SYSTEM
    Computer: MACHINE-NAME
    Description:
    Unable to start a DCOM Server: {99169CB1-A707-11D0-989D-00C04FD919C1}
    as
    ./IWAM_MACHINE-NAME. The error: "Access is denied. " Happened while
    starting
    this command: C:\WINNT\System32\dllhost.exe
    /Processid:{3D14228D-FBE1-11D0-995D-00C04FD919C1}

    --OR--

    Displayed in Web Browser:

    Error: Access is Denied.

    Displayed in System Log:

    Event Type: Warning
    Event Source: W3SVC
    Event Category: None
    Event ID: 30
    Date: 3/5/2001
    Time: 10:01:13 AM
    User: N/A
    Computer: MACHINE-NAME
    Description:
    The server was unable to read the file
    C:\WINNT\help\iisHelp\common\401-3.htm.
    The file does not exist. For additional information specific to this
    message
    please visit the Microsoft Online Support site located at:
    http://www.microsoft.com/contentredirect.asp.

    CAUSE
    =====

    NTFS permissions have been changed from the defaults and are no longer
    sufficient for IIS 5.0 to run properly.

    RESOLUTION
    ==========

    NOTE: Following this article will restrict permissions so that only
    Administrators will be able to install or run software on the IIS 5.0
    machine.
    It will also be necessary to perform a "Check Server Extensions" for
    each web
    site through Internet Service Manager in order for FrontPage clients to
    be able
    to connect via the HTTP protocol.

    Using Windows Explorer do the following:

    1. Reset the entire hard drive to:

    SYSTEM - Full Control
    ADMINISTRATORS - Full Control
    This includes clicking "Advanced" and checking "Reset permissions on
    all child
    objects and enable propagation of inheritable permissions." You will
    receive
    an error while trying to apply permissions to pagefile.sys. Press
    continue on
    this and any other similar errors.

    2. For "Program Files\Common Files" Add:

    Everyone - Read and Execute, List Folder Contents, Read
    (Leave "Allow inheritable permissions from parent to propagate to
    this object"
    checked)

    3. For "Inetpub\Wwwroot" Add:

    IUSR_MACHINE - Read and Execute, List Folder Contents, Read
    (Leave "Allow inheritable permissions from parent to propagate to
    this object"
    checked)

    4. Inside the "WinNT\System32" directory select:

    All FOLDERS (except INETSRV and CERTSRV if present).
    Open "Properties" for these folders and uncheck "Allow inheritable
    permissions
    from parent to propagate to this object." When Windows asks whether
    to
    "[Copy] [Remove] [Cancel]" click "COPY."
    Click "Okay" to exit the properties.

    5. Inside the "WinNT" directory select:

    All FOLDERS (except Downloaded Program Files, Help, IIS Temporary
    Compressed
    Files, Offline Web Pages, System32, Tasks, Temp, Web).
    Open "Properties" for these folders and uncheck "Allow inheritable
    permissions
    from parent to propagate to this object." When Windows asks whether
    to
    "[Copy] [Remove] [Cancel]" click "COPY."
    Click "Okay" to exit the properties.

    6. For "WinNT" Add:

    Everyone - Read and Execute, List Folder Contents, Read
    (Leave "Allow inheritable permissions from parent to propagate to
    this object"
    checked)

    7. For "WinNT\Temp" (This allows Access databases to be viewed on ASP
    pages):

    Highlight the "Everyone" group. (This group should already be present
    by
    inheriting from the "WinNT" directory.)
    Check "Modify"

    MORE INFORMATION
    ================

    Why you should use the EVERYONE group instead of the IUSR_MACHINE
    account:

    The everyone group encompasses the Users group, the IUSR_MACHINE
    account, and the
    IWAM_MACHINE account.

    IIS 5.0 uses two separate accounts to execute web pages. When anonymous
    authentication is used IIS uses the IUSR_MACHINE account to view those
    pages.
    However, IWAM_MACHINE is used to start up a separate process called
    DLLHOST.EXE.
    All ASP, COM components, or other ISAPI extensions (ASP is considered an
    ISAPI
    extension) are run inside this DLLHOST.EXE. This is primarily for
    stability
    purposes. If a custom COM component called from an ASP page crashes
    (Access
    Violates thus shutting down the process) it will not effect
    INETINFO.EXE. This
    means the web service will continue to run.

    There are two protection levels in IIS 4.0:

    Default - IIS 4.0 runs all "Applications" In-Process meaning inside
    the
    INETINFO.EXE process, which gets started up by the SYSTEM account.
    When web
    pages are viewed the particular thread that is serving the page is
    run under
    the context of the IUSR_MACHINE account. HTM, ASP and any other ISAPI
    extensions are run inside the INETINFO.EXE process.

    Run in Separate Memory Space (Isolated Process) - This is also knows
    as
    Out-Of-Process. This uses the IWAM_MACHINE account to spawn a
    separate
    MTX.EXE process that runs ASP and other ISAPI extensions.

    There are three protection levels in IIS 5.0:

    Low (IIS Process) - This setting is similar to the default setting
    under IIS
    4.0. All web pages whether HTM or ASP are run inside the INETINFO.EXE
    process.

    Medium (Pooled) - This is the default. As with IIS 4.0 this setting
    starts a
    separate process called DLLHOST.EXE where all ASP and COM components
    are run.
    This process is started by the IWAM_MACHINE account just as in IIS
    4.0. Also,
    this setting is known as pooled because even if there are 5000
    different web
    sites running in IIS, they will all share this single DLLHOST.EXE for
    executing ASP pages (Windows 2000 replaces MTX.EXE with DLLHOST.EXE).

    High (Isolated) - This setting starts a dedicated DLLHOST.EXE for
    that
    particular web site or application. If you had 5 web sites each set
    on High
    protection you would see five DLLHOST.EXE processes plus one
    additional
    DLLHOST.EXE that COM+ starts under the "System Application" for a
    total of
    six DLLHOST.EXE's

    To restore default NTFS permissions for Windows 2000 please see:
    Q266118 How to Restore the Default NTFS Permissions for Windows 2000

    Additional query words: iis 5 NTFS permission

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles