www.webdeveloper.com
Results 1 to 6 of 6

Thread: Javascript IE6 problem, please help

  1. #1
    Join Date
    Jan 2005
    Location
    UK
    Posts
    381

    Javascript IE6 problem, please help

    Hi Folks,

    I've got a drag and drop interface working using bbc's glow, its great, but I have a slight problem.

    The script at the top of the page creates the widgets using dom functions. It gets the order from a string stored in a cookie. The widgets are also in the page as a default layout incase JS is turned off.

    This works fine in FF. However in IE, the default widget layout flashes for a couple of seconds, then JS creates the new layout. Is there anyway to stop this?

    Is it to do with the way IE reads the page?

    I have abasic example here, if you drag and drop a heading in a blue box, refresh the page, you should see the default appear for a few seconds before the JS kick in.

    http://www.sandwell.nhs.uk/test/index.html

    Can anyone please help?

    Thankyou

  2. #2
    Join Date
    Dec 2003
    Location
    Bucharest, ROMANIA
    Posts
    15,428
    You must be kidding: in IE6 the code does not work at all (nor you should worry - let's hope IE6 will dissapear till the end of the year)

    Now, at a first glance: You have used an XHTML Doctype, but a HTML notation for the nonempty elements. Make up your mind: XHTML or HTML?. My advice: if you do not need to handle XML objects, use a HTML 4.01 strict Doctype (and HTML notation). It will be enough.

  3. #3
    Join Date
    Jan 2005
    Location
    UK
    Posts
    381
    Thanks for your reply.

    It works for me in IE6???!!!! sorry I dont understand.

    I've changed it to strict but I get the same problem.

    Any ideas?

  4. #4
    Join Date
    Dec 2003
    Location
    Bucharest, ROMANIA
    Posts
    15,428
    It simply does not work for me : IE 6.0.2900.2180 on XP/SP2. No error. Just that the drag'n'drop does not work.

    And: you still have the XHTML Doctype.

    Read more about Doctypes:
    http://www.w3schools.com/tags/tag_DO...e6777008520db9

  5. #5
    Join Date
    Jan 2005
    Location
    UK
    Posts
    381
    Thanks again for our reply.

    Thats very weird.

    Its deffo here:

    http://www.sandwell.nhs.uk/test/portaltest.html

    I done a refresh and the page definately works in IE 6.0.3790

    Could you try again for me please?

    If you move a widget and refresh the page, whilst it loads it shows the default layout. I was after a way to stop that.

    Thanks again

  6. #6
    Join Date
    Dec 2003
    Location
    Bucharest, ROMANIA
    Posts
    15,428
    I have tested the page in all the browsers I have.

    It works on: IE7, IE8, FF 3.5, Opera 10, Chrome, Safari (for Win)
    It does not work on: IE6

    OS: Win XP/SP2

    It is true that my IE6 is not independent, it is a part of a virtual IE Collection (which helped me to install the IE versions all together), but this would not matter, as far as I know.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles