www.webdeveloper.com
Results 1 to 1 of 1

Thread: New Problem

  1. #1
    Join Date
    Sep 2008
    Posts
    205

    New Problem

    hi everyone one i made a webservice in php to get string and transform this string into upper case and also i made another function to make a mirror for my text

    EX:
    john will return JOHN and nhoj in the second function


    the user of my website wants to use this webservice but in .NET


    my WSDL code is:
    Code:
    <?xml version ='1.0' encoding ='UTF-8' ?>
    <definitions name='Scramble' 
      targetNamespace='http://www.o-survey.com/john_test/johns/scramble2.wdsl' 
      xmlns:tns='http://www.o-survey.com/john_test/johns/scramble2.wdsl' 
      xmlns:soap='http://schemas.xmlsoap.org/wsdl/soap/' 
      xmlns='http://schemas.xmlsoap.org/wsdl/'> 
    
    <message name='getRot13Request'> 
      <part name='symbol' type='xsd:string'/> 
    </message> 
    <message name='getRot13Response'> 
      <part name='Result' type='xsd:string'/> 
    </message> 
    <message name='getMirrorRequest'> 
      <part name='symbol' type='xsd:string'/> 
    </message> 
    <message name='getMirrorResponse'> 
      <part name='Result' type='xsd:string'/> 
    </message> 
    
    <portType name='ScramblePortType'> 
      <operation name='getRot13'>
        <input message='tns:getRot13Request'/> 
        <output message='tns:getRot13Response'/>   
      </operation>
      <operation name='getMirror'>
        <input message='tns:getMirrorRequest'/> 
        <output message='tns:getMirrorResponse'/>   
      </operation>    
    
    </portType> 
    
    <binding name='ScrambleBinding' type='tns:ScramblePortType'> 
      <soap:binding style='rpc' 
        transport='http://schemas.xmlsoap.org/soap/http'/> 
      <operation name='getRot13'> 
        <soap:operation soapAction='urn:localhost-scramble#getRot13'/> 
        <input> 
          <soap:body use='encoded' namespace='urn:localhost-scramble' 
            encodingStyle='http://schemas.xmlsoap.org/soap/encoding/'/> 
        </input> 
        <output> 
          <soap:body use='encoded' namespace='urn:localhost-scramble' 
            encodingStyle='http://schemas.xmlsoap.org/soap/encoding/'/> 
        </output> 
      </operation>
      <operation name='getMirror'> 
        <soap:operation soapAction='urn:localhost-scramble#getMirror'/> 
        <input> 
          <soap:body use='encoded' namespace='urn:localhost-scramble' 
            encodingStyle='http://schemas.xmlsoap.org/soap/encoding/'/> 
        </input> 
        <output> 
          <soap:body use='encoded' namespace='urn:localhost-scramble' 
            encodingStyle='http://schemas.xmlsoap.org/soap/encoding/'/> 
        </output> 
      </operation>       
    
    </binding> 
    
    <service name='ScrambleService'> 
      <port name='ScramblePort' binding='ScrambleBinding'> 
        <soap:address location='http://www.o-survey.com/john_test/johns/server2.php'/> 
      </port> 
    </service>
    </definitions>
    My problem is that when the user tried to get the result in .NET he received the attached error image.

    i tried to test my webservice in the website http://www.soapclient.com/soaptest.html and i put in the text field this link http://www.o-survey.com/john_test/johns/scramble2.wsdl and it get result so how i can solve this one? or where is the error
    Attached Images Attached Images
    Attached Files Attached Files

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles