www.webdeveloper.com
Results 1 to 6 of 6

Thread: Latest "Download flash" install script is messing up my css

  1. #1
    Join Date
    Nov 2009
    Posts
    21

    Latest "Download flash" install script is messing up my css

    It seems Flash has a new version out and embedded it's code into my site. It includes the "object" tag which IE doesn't support? So when I made the latest changes and uploaded the site it doesn't work in IE anymore. When I take out the object tag is messes up all my CSS for the other browsers. Anyone know what's going on??

  2. #2
    Join Date
    Feb 2008
    Location
    NW Washington State
    Posts
    1,856
    Hard to diagnose problem without seeing it. Post a link.
    <object> works just fine with IE so could be something else.
    Have you tried swfobject? It's a better way to place Flash on the page. It allow for the use of "Alternate content" to make your Flash content more SEO friendly.
    Best wishes,
    Eye for Video
    www.cidigitalmedia.com

  3. #3
    Join Date
    Nov 2009
    Posts
    21
    Thanks for your help! It's howlandplacefitnesscenter.com

  4. #4
    Join Date
    Feb 2008
    Location
    NW Washington State
    Posts
    1,856
    What exactly is the problem? Be very specific.
    What other browsers are you testing in?
    EfV

  5. #5
    Join Date
    Nov 2009
    Posts
    21
    Since the new flash plug-in "notification" was put on the page, none of the links drop down anymore....and only the flash movie is visible. When I open it up in Dreamweaver to try to figure out the problem Dreamweaver says it's the "object" tag which "may not work in newer version of IE". When I try to modify that tag in anyway...the rest of my CSS gets all messed up. For example my first 2 div tags "container" and "mainContent" turn black and no longer seem active so everything just bounces all over the page. I can't seem to get those 2 containers working again to hold things together...and have everything function.

  6. #6
    Join Date
    Feb 2008
    Location
    NW Washington State
    Posts
    1,856
    After a quick look it seems to me that there is a <div> tag missing or not closed properly.
    The <object> tag of and by itself will not affect the css layout, but if, in the process of putting it in, the <div> layout gets screwed up, then that's a problem.
    Also, the video displays in IE but not in FF. Often that's an indication of a <div> problem. Looks like you are trying to use swfobject.... so how about this.
    A good practice when using swfobject is to create your alt content first and then only after you get that working, add the Flash content.
    So to straighten this out, remove the Flash content, just create all your <div>s, including the one which will eventually hold the Flash. Give that <div> the exact same dimensions as your Flash and give it a background color which will stick out on the page. Style the rest of the page around that Flash container. Once you get that all working, then place the Flash inside.
    If you don't want to use swfobject, you could always just use this:
    Code:
    <object data="path_to_file/file.swf" type="application/x-shockwave-flash" width="insert_width_of_movie" height="insert_height_of_movie">                    
              	<param name="movie" value="path_to_file/file.swf">
    <param name="SomeOtherParam" value="ParamValue">
    </object>
    Best wishes,
    EfV

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles