www.webdeveloper.com
Results 1 to 3 of 3

Thread: Page not showing up in IE... Why?

Hybrid View

  1. #1
    Join Date
    Dec 2010
    Posts
    10

    Page not showing up in IE... Why?

    Ok for some reason I have a new problem with IE 8. On my website www.hidcountry.com when a customer clicks a product button on the left side navbar it triggers JQuery code that makes it dropdown with other products and at the same time it loads page content into a mainContent div on the right. Everything works just fine in Firefox but in IE, it comes up as a blank page... No content. Why is this?

  2. #2
    Join Date
    Aug 2006
    Posts
    1,922
    Apologies for being blunt, but that page is a mish-mash of html, xhtml, deprecated and illegal code. IE's nature is to be picky and require code to be standard, so it's no surprise that you're having trouble. I wouldn't even know where to start regarding that particular bug, but perhaps the Validator results might give you some pointers.

    Start with picking a language (html or xhtml) and stating it in a DOCTYPE at the top of the file.

    Dave

  3. #3
    Join Date
    Dec 2010
    Posts
    10

    Exclamation

    The thing is that these "content" pages that display in Firefox are just the mainContent div from pages like HID Kits (top nav). I just took the inside code and using JQuery with the links on the sidebar nav, it points to a page in a content folder that has the div info... It's hard to explain but the other pages work and these pages don't and the code is only slightly different... Do you think it might be the JQuery affecting the info?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles