www.webdeveloper.com
Results 1 to 4 of 4

Thread: strange error when clicking on certain links

  1. #1
    Join Date
    Feb 2011
    Posts
    2

    strange error when clicking on certain links

    I made a small site that works perfectly except for a strange bug. Occasionally, when I click the "previous" button or "next" button (both of which link to different pages) on a page, I notice the page won't load, but when I try again, sometimes it does load. Maybe something is wrong with my internet connection, but this behavior is strange.

    The links are plain HTML links, and the URLs are fine...Occasionally the page will load when I click the link, but sometimes it won't without several tries. And when it does load, it often loads relatively quickly. I don't think the pages are too heavy with bandwidth sucking graphics. There's no pattern that I can see.

    Is it possible this is happening because my browser (I have tried several types) has problems rendering the javascript on the page? The javascript in question just balances out the page's column heights. Nothing too fancy.

    I asked my hosting company (HostGator) about it, but they say the server's fine and state that my Internet connection might be intermittent.

    I really don't know what it is. Any help would be great.

  2. #2
    Join Date
    Mar 2010
    Posts
    2,803
    I'm not sure what sort of help you expect in debugging your code if you don't post it.

  3. #3
    Join Date
    Feb 2011
    Posts
    231
    That problem appear in other browser too?
    It's happen only on that web site or other site too?
    A correct and smart question can give half an answer.

  4. #4
    Join Date
    Feb 2011
    Posts
    2

    here's some of the code

    <div id="post">

    <p class="earlier"><a href="http://www.dietjoker.com/home32.shtml" class="black" target="_blank">Previous</a></p>

    <p class="later"><a href="http://www.dietjoker.com/home34.shtml" class="black" target="_blank">Next</a></p>

    </div>

    The above is the code the URLs are embedded in...

    I have tested the browssers internet explorer, opera, and firefox.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles