Results 1 to 12 of 12

Thread: Consume Non-CF Web Service

  1. #1
    Join Date
    Jul 2010

    Consume Non-CF Web Service

    Hey guys,

    I just got a job at a company that uses CF as its server side language. I'm a quick learner and have the basics ironed out so my boss gave me a project that seems above my league but before I tell him, I'd like to know if there is anything I could try. And I've looked thru all relevant adobe pages and multiple forum and blog posts.

    Now, as the title goes, this is about a web service a client of ours has that he wants us to use. I've found the WSDL doc and all the imports it has, but for the life of me, I cannot get the service to run or display any form of error to tell me whats happening, aside from an error on my side.

    From the error it looks like I'm getting an error returned from the service but I get a semantic error when the compiler attempt to set an int to a java.lang.integer.

    The service file is a .SVC extension. And the crazy thing the error which should be that nice table is instead the HTML of the table and everything on the page (as in the html is shown on the page)

    Is there anything more you need to know to help me?

  2. #2
    Join Date
    Dec 2002
    St. Louis, MO, USA
    Off the top of my head, the only thing I can think of is to check and make sure that if any specific CF settings are required in CFAdmin, they are set.

    What are the error messages?


  3. #3
    Join Date
    Jul 2010
    Hey sorry it took so long for a replay and thanks for replying as well

    K, well, got to work this morning and had an email (I had sent an email to their dev team asking about the error, it seems it was on their end) Since this, I'm not getting the same error but now a new one.

    Cannot generate stub objects for web service invocation.

    But not to worry, as of right now, the fault is on their end as it is stating its an invalid wsdl, so lets hope after it gets straighted out I can get this to work.


  4. #4
    Join Date
    Jul 2010
    Just got a response from the guy.

    Not sure on how to answer this.

    Yeah, I understand this oneÖI believe. The issue is that WSDL is not on the https protocol, itís on HTTP. The web service is on HTTPS. So given that, Iím not sure the ramifications.
    Are you able to read the wsdl with one address and specify the end-point with another.

    Example. We nearly always develop against a QA instance of a web service, which usually used to read the WSDL. We then repoint our apps to the correct URL later, it never re-reads the WSDL and used the correct URL.

    I think in this case that Cold Fusion is trying to read the WSDL and assuming that is also the same URL for the call, which in this case itís not.
    I'm still getting that previous error and I don't know how to proceed.

  5. #5
    Join Date
    Jul 2010
    From what I've researched, CF will not accept any secure url locations without first having the cert in its storage location.

    Any idea how to do this in an easy way without some command line?

  6. #6
    Join Date
    Dec 2002
    St. Louis, MO, USA
    This is news, to me. I've never had any trouble (in the two times I was designated CFAdmin) with getting CF server to use SSL; SSL was done via IIS, and worked, each time - nothing about storing the cert in CF.

    Scratching my head on that one.


  7. #7
    Join Date
    Jul 2010
    Hmm I just tried adding the wsdl url using the cfide admin web service section and it gave me a "the url is wrong" type error but I can clearly get to it using the browser.

  8. #8
    Join Date
    Jul 2010
    Actually this is odd,

    if I use the https with the url I get to basically a landing page on how to create a client for this web service, removing the 'https://' takes me to the actual wsdl doc, I guess thats the problem?

  9. #9
    Join Date
    Dec 2002
    St. Louis, MO, USA
    That could be it. Odd that an SSL protocol would redirect you to such a page.


  10. #10
    Join Date
    Jul 2010
    Hmm... so we still haven't imported the cert, hopefully, we'll get that done today or tomorrow.

    Now, if it's not that and is in fact the WSDL is on an 'http' protocol while the web service is on an 'https' protocol causing the problem, do you know how to go about solving this issue?

  11. #11
    Join Date
    Dec 2002
    St. Louis, MO, USA
    I do not. Create an account on Adobe.com (if you haven't got one already) and use their CF forum. Very knowledgeable people, there.


  12. #12
    Join Date
    Dec 2002
    St. Louis, MO, USA
    Should have included the link to it. Sorry.



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center



X vBulletin 4.2.2 Debug Information

  • Page Generation 0.12186 seconds
  • Memory Usage 2,958KB
  • Queries Executed 15 (?)
More Information
Template Usage (33):
  • (1)ad_footer_end
  • (1)ad_footer_start
  • (1)ad_global_above_footer
  • (1)ad_global_below_navbar
  • (1)ad_global_header1
  • (1)ad_global_header2
  • (1)ad_navbar_below
  • (1)ad_showthread_firstpost_sig
  • (1)ad_showthread_firstpost_start
  • (1)ad_thread_first_post_content
  • (1)ad_thread_last_post_content
  • (1)bbcode_quote
  • (1)footer
  • (1)forumjump
  • (1)forumrules
  • (1)gobutton
  • (1)header
  • (1)headinclude
  • (1)headinclude_bottom
  • (12)memberaction_dropdown
  • (1)navbar
  • (4)navbar_link
  • (1)navbar_moderation
  • (1)navbar_noticebit
  • (1)navbar_tabs
  • (2)option
  • (12)postbit
  • (12)postbit_onlinestatus
  • (12)postbit_wrapper
  • (1)spacer_close
  • (1)spacer_open
  • (1)tagbit_wrapper 

Phrase Groups Available (6):
  • global
  • inlinemod
  • postbit
  • posting
  • reputationlevel
  • showthread
Included Files (26):
  • ./showthread.php
  • ./global.php
  • ./includes/class_bootstrap.php
  • ./includes/init.php
  • ./includes/class_core.php
  • ./includes/config.php
  • ./includes/functions.php
  • ./includes/functions_navigation.php
  • ./includes/class_friendly_url.php
  • ./includes/class_hook.php
  • ./includes/class_bootstrap_framework.php
  • ./vb/vb.php
  • ./vb/phrase.php
  • ./includes/functions_facebook.php
  • ./includes/functions_calendar.php
  • ./includes/functions_bigthree.php
  • ./includes/class_postbit.php
  • ./includes/class_bbcode.php
  • ./includes/functions_reputation.php
  • ./includes/functions_notice.php
  • ./packages/vbattach/attach.php
  • ./vb/types.php
  • ./vb/cache.php
  • ./vb/cache/db.php
  • ./vb/cache/observer/db.php
  • ./vb/cache/observer.php 

Hooks Called (72):
  • init_startup
  • friendlyurl_resolve_class
  • init_startup_session_setup_start
  • database_pre_fetch_array
  • database_post_fetch_array
  • init_startup_session_setup_complete
  • global_bootstrap_init_start
  • global_bootstrap_init_complete
  • cache_permissions
  • fetch_postinfo_query
  • fetch_postinfo
  • fetch_threadinfo_query
  • fetch_threadinfo
  • fetch_foruminfo
  • load_show_variables
  • load_forum_show_variables
  • global_state_check
  • global_bootstrap_complete
  • global_start
  • style_fetch
  • global_setup_complete
  • showthread_start
  • showthread_getinfo
  • strip_bbcode
  • friendlyurl_clean_fragment
  • friendlyurl_geturl
  • forumjump
  • cache_templates
  • cache_templates_process
  • template_register_var
  • template_render_output
  • fetch_template_start
  • fetch_template_complete
  • parse_templates
  • fetch_musername
  • notices_check_start
  • notices_noticebit
  • process_templates_complete
  • friendlyurl_redirect_canonical
  • showthread_post_start
  • showthread_query_postids
  • showthread_query
  • bbcode_fetch_tags
  • bbcode_create
  • showthread_postbit_create
  • postbit_factory
  • postbit_display_start
  • postbit_imicons
  • bbcode_parse_start
  • bbcode_parse_complete_precache
  • bbcode_parse_complete
  • postbit_display_complete
  • memberaction_dropdown
  • tag_fetchbit_complete
  • forumrules
  • navbits
  • navbits_complete
  • build_navigation_data
  • build_navigation_array
  • check_navigation_permission
  • process_navigation_links_start
  • process_navigation_links_complete
  • set_navigation_menu_element
  • build_navigation_menudata
  • build_navigation_listdata
  • build_navigation_list
  • set_navigation_tab_main
  • set_navigation_tab_fallback
  • navigation_tab_complete
  • fb_like_button
  • showthread_complete
  • page_templates