www.webdeveloper.com
Results 1 to 4 of 4

Thread: PHP.ini ignores PATH directive (Windows)

  1. #1
    Join Date
    Feb 2008
    Posts
    78

    PHP.ini ignores PATH directive (Windows)

    Hello, the php.ini file in my xampp installation is ignoring this PATH directive:

    Code:
    [PATH=C:/xampp/htdocs]
    disable_functions = apache_child_terminate, apache_setenv, define_syslog_variables, escapeshellarg, escapeshellcmd, eval, exec, fp, fput, ftp_connect, ftp_exec, ftp_get, ftp_login, ftp_nb_fput, ftp_put, ftp_raw, ftp_rawlist, highlight_file, ini_alter, ini_get_all, ini_restore, inject_code, mysql_pconnect, openlog, passthru, php_uname, phpAds_remoteInfo, phpAds_XmlRpc, phpAds_xmlrpcDecode, phpAds_xmlrpcEncode, popen, posix_getpwuid, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, posix_setuid, posix_uname, proc_close, proc_get_status, proc_nice, proc_open, proc_terminate, shell_exec, syslog, system, xmlrpc_entity_decode, phpinfo
    I've tried:

    Putting it into quotes.
    Taking out the C:/.
    And even using relative paths.

    Thankyou,
    GB.
    Last edited by GB_001; 05-15-2011 at 01:12 AM.

  2. #2
    Join Date
    Aug 2004
    Location
    Ankh-Morpork
    Posts
    19,251
    What exactly are you trying to set? In the php.ini file, text in square brackets is only used as section markers and is ignored the same as commented text. In any case, PATH is not a valid php.ini setting item to the best of my knowledge. Do you want to set include_path, perhaps?
    "Please give us a simple answer, so that we don't have to think, because if we think, we might find answers that don't fit the way we want the world to be."
    ~ Terry Pratchett in Nation

    eBookworm.us

  3. #3
    Join Date
    Feb 2008
    Posts
    78
    Quote Originally Posted by NogDog View Post
    What exactly are you trying to set? In the php.ini file, text in square brackets is only used as section markers and is ignored the same as commented text. In any case, PATH is not a valid php.ini setting item to the best of my knowledge. Do you want to set include_path, perhaps?
    I'm including rules for a specific path as shown here: http://www.php.net/manual/en/ini.sections.php

    It seems to be ignoring it though.

  4. #4
    Join Date
    Aug 2004
    Location
    Ankh-Morpork
    Posts
    19,251
    The manual says, "These sections are used only in CGI/FastCGI mode and they can not set extension and zend_extension directives." Does this apply to your situation (CGI/FastCGI)?
    "Please give us a simple answer, so that we don't have to think, because if we think, we might find answers that don't fit the way we want the world to be."
    ~ Terry Pratchett in Nation

    eBookworm.us

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles