www.webdeveloper.com
Results 1 to 2 of 2

Thread: PHP exec a batch file terminates before compliting on IIS7

Threaded View

  1. #1
    Join Date
    May 2011
    Posts
    4

    PHP exec a batch file terminates before compliting on IIS7

    Hi,

    The website that I am making involves executing 3 batch files.
    I am executing the batch files using the exec function.
    When I test the website code on my personal PC with apach server, it is working fine
    The execution of the 3 batch files is done one after the other just like it is supposed to do.

    But I'm having a problem with executing the batch files on my VPS IIS7 server.
    For some reason, the execution of the batch files terminates before it is over.
    When I execute the batch files from CMD, they are working fine.

    I tried to give more time in the max_execution_time (in the php.ini) but it did not make a different.
    I tried to change the limits properties in the IIS manager but still I did not notice any difference.

    I am new to windows server 2008 (my first time )

    I have 2 questions:
    1. Is there an error log for web sessions that logs web sessions and through that I will be able to see why the execution of the batch file terminated?
    2. Has anyone encountered a problem like I described above?

    Thanks for the help.
    Last edited by arnonch; 06-13-2011 at 01:48 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles