First off I tried installing tomcat via eclipse, that brought about these results, which I'm pretty oblivious to. I chose my mac's default 'JVM Contents' JRE, and tried starting the server and I got this.

Jun 22, 2011 12:36:03 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java
Jun 22, 2011 12:36:04 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8080"]
Jun 22, 2011 12:36:04 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
Jun 22, 2011 12:36:04 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1481 ms
Jun 22, 2011 12:36:04 AM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
Jun 22, 2011 12:36:04 AM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.16
Jun 22, 2011 12:36:04 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8080"]
Jun 22, 2011 12:36:04 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
Jun 22, 2011 12:36:04 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 666 ms


Next I tried installing it via terminal following this URL's instructions but I couldn't get my localhost:8080 to show the correct page, all i get is a 404 page saying 'The requested resource (/) is not available.' from tomcat. I've been struggling with this for the past 2 days and my frustrations getting the best of me at this point