www.webdeveloper.com
Results 1 to 7 of 7

Thread: Bug in PHP 5.3.7, wait for 5.3.8

  1. #1
    Join Date
    Aug 2004
    Location
    Ankh-Morpork
    Posts
    19,333

    Bug in PHP 5.3.7, wait for 5.3.8

    As per http://www.php.net/archive/2011.php#id2011-08-22-1, there is a bug in PHP 5.3.7 for the crypt() function, and therefore they are recommending users to not upgrade to the recent 5.3.7 release, but instead wait for 5.3.8.
    "Please give us a simple answer, so that we don't have to think, because if we think, we might find answers that don't fit the way we want the world to be."
    ~ Terry Pratchett in Nation

    eBookworm.us

  2. #2
    Join Date
    Jan 2009
    Posts
    3,346
    Good to know. Are they plannning to remove the download or only users who manage to find the discussion will know why it is broken?

  3. #3
    Join Date
    Aug 2004
    Location
    Ankh-Morpork
    Posts
    19,333
    Quote Originally Posted by criterion9 View Post
    Good to know. Are they plannning to remove the download or only users who manage to find the discussion will know why it is broken?
    You'll have to ask them, not me.

    PS: There is a fix in SVN there should you have installed 5.3.7 and your code uses crypt() with a salt (otherwise as far as I can tell you should not be affected by the bug).
    Last edited by NogDog; 08-22-2011 at 02:07 PM.
    "Please give us a simple answer, so that we don't have to think, because if we think, we might find answers that don't fit the way we want the world to be."
    ~ Terry Pratchett in Nation

    eBookworm.us

  4. #4
    Join Date
    Jan 2009
    Posts
    3,346
    Quote Originally Posted by NogDog View Post
    You'll have to ask them, not me.

    PS: There is a fix in SVN there should you have installed 5.3.7 and your code uses crypt() with a salt (otherwise as far as I can tell you should not be affected by the bug).
    Good thing I'm still a version back.

  5. #5
    Join Date
    Aug 2004
    Location
    Ankh-Morpork
    Posts
    19,333
    Quote Originally Posted by criterion9 View Post
    Good thing I'm still a version back.
    My web host is still on 5.2.something, but don't tell anyone.
    "Please give us a simple answer, so that we don't have to think, because if we think, we might find answers that don't fit the way we want the world to be."
    ~ Terry Pratchett in Nation

    eBookworm.us

  6. #6
    Join Date
    Aug 2010
    Location
    Ohio
    Posts
    136
    Apparently I'm two back on all 3 of my servers! 5.3.5!

  7. #7
    Join Date
    Aug 2010
    Location
    Ohio
    Posts
    136

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles