www.webdeveloper.com
Results 1 to 2 of 2

Thread: Apache2 and .htaccess

Hybrid View

  1. #1
    Join Date
    Jul 2011
    Posts
    5

    Apache2 and .htaccess

    Hi all,

    I currently run a small IRC server (irc.website.com). irc.website.com resolves to 10.20.30.40. The IRC server has the following stuff in it (/home/website):

    ircd/
    logs/
    public_html/
    services/
    passwd (linked in .htaccess)

    Under /public_html is a sub-folder called logs, which has two folders: channel-logs and private-logs. The .htaccess file is under /public_html/logs. Here's the stuff in it:
    Code:
    AuthName "Enter Password"
    AuthType Basic
    AuthUserFile /home/website/passwd
    Require valid-user
    I have a VirtualHost set up for irclogs.website.com (I have to distribute this link to others) that uses the .htaccess info to log in. However, when irc.website.com is typed, it prompts me for a username/password, and uses the .htaccess file under /public_html/logs.
    VirtualHost:
    Code:
    NameVirtualHost 10.20.30.40:80
    
    <VirtualHost 10.20.30.40:80>
            ServerName irclogs.website.com
            ServerAlias irclogs.website.com
    	DocumentRoot /home/website/public_html/logs
    	ServerAdmin webmaster@website.com
            UseCanonicalName Off
    
     #DocumentRoot /home/website/public_html/logs
     #Directory /home/website/public_html/logs
     #AuthDBMUserFile /home/website/passwd
    
    	<Directory />
    		Options FollowSymLinks
    		AllowOverride None
    	</Directory>
    	<Directory /home/website/public_html/logs>
    		Options Indexes FollowSymLinks MultiViews
    		AllowOverride AuthConfig
    		Order allow,deny
    		allow from all
                    AuthName "Private"
                    AuthType Basic
                    AuthBasicProvider dbm
                    AuthDBMUserFile /home/website/passwd
                    Require valid-user
    	</Directory>
    	ScriptAlias /cgi-bin/ /home/website/public_html/cgi-bin/
    	<Directory "/home/website/public_html/cgi-bin/">
    		AllowOverride None
    		Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
    		Order allow,deny
    		Allow from all
    	</Directory>
    
    	ErrorLog /home/website/logs/website_error.log
    
    	# Possible values include: debug, info, notice, warn, error, crit,
    	# alert, emerg.
    	LogLevel warn
    
    	CustomLog /home/website/logs/website_access.log combined
            CustomLog /home/website/logs/website.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."
    	ServerSignature On
    
     </VirtualHost>
    Basically, I don't want "irc.website.com" to be accessible from the browser. I only want that to be used when users are connecting to the IRC server. I'm not too good with VirtualHosts (still getting the hang of it). OS = Ubuntu with Apache2.

    Any help is appreciated. Thanks!

  2. #2
    Join Date
    Jul 2011
    Posts
    5
    Any guesses/ideas? I'm willing to try anything at this point.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles