www.webdeveloper.com
Results 1 to 3 of 3

Thread: z-index problems in IE

Hybrid View

  1. #1
    Join Date
    Jun 2011
    Posts
    10

    Question z-index problems in IE

    Hi,
    I have some problems with a flashbanner (see screenshot) interfering with the fancybox product lightbox background in my shopping cart. Some of the flash is running on top of the edges of the lightbox. It only occurs in IE. I have tried to sort it by adding a z-index="0" to the flash script but it hasn't helped.

    using IE to recreate go to :

    http://www.barcodebonanza.co.uk/prod...SCAN-D131.html

    click on the product to enlarge.

    Thanks
    Attached Images Attached Images

  2. #2
    Join Date
    Nov 2011
    Posts
    19
    Hi

    By default, the Flash plugin will do a weird thing. Instead of being displayed inside the browser, it actually makes a new window on top of the browser which synchronises it’s position with where you’d expect the flash should be. (In real it's a bit more complicated )

    The solution is simple. With an extra parameter, you can force the flash to render in a different window mode.

    1.Set wmode=transparent by adding a parameter as follows for it to work in IE.

    Code:
    <PARAM NAME="WMODE" VALUE="transparent">
    2.For other browsers, set wmode=”transparent” in the embed tag

    Code:
    wmode="transparent"
    Now Your z-index rule will work

    -------------
    Jacek Jeznach
    Web developer

  3. #3
    Join Date
    Jun 2011
    Posts
    10

    Talking Thanks!

    YEEESSSS! it works. Thanks Jacek

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles