Hey Guys,

I am an ASP.NET NOOB, so i want to apologize if i am unclear on some of the details below. I am moving a website from one windows server to another and am having issues galore. I am unsure of the previous servers environment, but we are running a brand new install of Windows Server 2008 R2 standard with iis 7.5 and VS2008 SP1. We simply want to make the site run on our new server, but its proving to be much more of a challenge that anticipated.

We have already done the following:
1) Successfully transferred the database
2) Edited the web.config file to connect to our database
3) Configured the site to run in .NET2.0 (this is what it seems to be designed for)
4) Installed the eCommerce software and referenced the dll
- This added a line in the web.config file that required commenting to keep the live site running. I commented this because we were receiving error Could not load file or assembly 'XXXX' or one of its dependencies. This problem is being worked on with the co-operation of the Third Party Software

Right now we are trying to open the project in VS2008 SP1 and it asks us to convert the project to a vs2008 project. We have a few different copies of the site and have tried it with all of them. After talking with someone who seems to know there way around visual studio we realized we don't have the full project and requested the full site. We were successful in receiving more files but still not sure if we have the right file. However when opening one of the files it does seem to be a bit different. For example in solutions explorer it has no files in it, there are two projects that appear, and the icon next to it is different(it shows a little grey folder. where the other ones show a little world symbol), also the top node is alot different too(The symbol shows a window with a little vs infinite symbol, and the name shows as Solution'XXXX', where the other files show a world symbol and file path reference to the sln file). Although i think there is something wrong, i open the .sln file and it asks to convert it, i continue, after converted you get a conversion log that tells you errors occurred and the solution explore shows pretty much nothing(other that what i explained earlier).

Not sure what the problem is, or if i even have the right file to work with. PLEASE PLEASE HELP ME!!! any info on anything in here would be greatly appreciated.

Thanks in advance