www.webdeveloper.com
Results 1 to 4 of 4

Thread: [RESOLVED] IE / ul List / background-Image bullet vertical align problem

  1. #1
    Join Date
    Jan 2012
    Posts
    3

    resolved [RESOLVED] IE / ul List / background-Image bullet vertical align problem

    Hi all,

    Anybody want to take a stab at this problem I am having? I have a list with bullet points styled with CSS that are not aligning properly vertically in IE 9. It seems that the background-image is getting cut off at the bottom in IE 9 browser, yet it displays correctly in Firefox 3 and up. Iím very new to CSS and alas, I have hit a wall with finding this specific fix. The page was developed in Dreamweaver CS5 and I have only tested this on the IE side via version 9. I am not sure if this problem exists in any earlier version of IE. I would be most appreciative if anyone could please take a look at my code and determine what I am doing wrong and or explain what I may be missing.

    Best Regards,

    Chris

    Sample Link:
    http://www.mantarails.com/testsite/techinfo.php

  2. #2
    Join Date
    May 2005
    Location
    Gold Coast (MS)
    Posts
    2,207
    May bot correct problem, but some errors:

    CSS

    HTML

    All minor errors. I see you have a CSS for IE 7. You might want to set one for IE 9 as IE does not calculate dimensions correctly to this day.

  3. #3
    Join Date
    Jan 2012
    Posts
    3
    Thanks Ron for the code check. I fixed the minor problems you had found, but these corrections unfortunately did not to fix my original problem. Thank you again though for taking a look under the hood for me.

    Chris

  4. #4
    Join Date
    Jan 2012
    Posts
    3

    Wink Fixed it:)

    I fixed this problem. My block text size had been 12px , so I made my sprite image 12px as well thinking this would properly align both the bullet image to the text. What I missed was that the font size at 12px is actually 14px in height which in turn would cause to have a two px difference in my spacing.
    So, what I thought had been a codding issue was in reality a image sprite to text spacing issue with regards to height.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles