www.webdeveloper.com
Results 1 to 2 of 2

Thread: IE woes: links (migrated from javascript forum)

  1. #1
    Join Date
    Nov 2005
    Location
    Bundanoon: first village to ban bottled water
    Posts
    221

    IE woes: links (migrated from javascript forum)

    IE (9,8,7 thru Parallels on a Mac) is not, or only partially, rendering styles on certain links; same behaviour across the versions:

    a[href^="javascript"] {
    text-decoration:underline; font-size:inherit; color:white; }
    a[href^="javascript"]:hover {background:#486; }

    —neither the underline nor the hover background are rendered, and the color is the same as surrounding text, so the links are not apparent: but they work;

    a[href^="http://"], a[href^="https://"] {
    text-decoration:underline; font-size:inherit; color:#bdbebf;}
    a[href^="http://"]:hover, a[href^="https://"]:hover {background:#468; }

    —the hover background doesn't work; the links work.

    Quirksmode says IE should honour these advanced attribute styles.

    This isn't the only IE problem I'm having, but one at a time—click on "welcome" to see the problem.

    Cheers.

  2. #2
    Join Date
    Nov 2005
    Location
    Bundanoon: first village to ban bottled water
    Posts
    221

    resolved

    "Compatability View" seems to fix the rendering. Haven't time to figure out why a later-model IE needs to be backwards-compatible to render, correctly, as do all the other major browsers.

    Any explanations ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles