www.webdeveloper.com
Results 1 to 2 of 2

Thread: [RESOLVED] Upload with gFTP breaks my pages!

  1. #1
    Join Date
    Mar 2011
    Posts
    103

    resolved [RESOLVED] Upload with gFTP breaks my pages!

    Hi. This is so weird and it's driving me nuts. If I have pages on a server that I uploaded using WinSCP from Windows 7. Today, I made some changes and re-uploaded the pages using gFTP in ArchLinux. Now I get 500 Internal Server Error on all the pages I uploaded from linux.

    It just doesn't make sense to me, but I know the problem has something to do with the Linux/gFTP combo I'm using to upload the pages. Can anyone make sense of this?

  2. #2
    Join Date
    Mar 2011
    Posts
    103
    Of course....I spend several hours trying to fix the problem, work up the gall to post a thread about it, then figure out the problem 5 minutes later. What I'm trying to say is sorry for wasting a post on something so stupid.

    At the very least, here was the problem in case this happens to anyone else:

    When a file get's uploaded to the server, it has some mask to set the default file permissions. I had to make sure that the files I was uploading had the SAME permissions on my local machine as they would have on the server. In other words, if you page files have permissions 644 on the server, then make sure they are 644 on your local machine.

    Still doesn't make sense to me, but hey, it's working now.

    Cheers,

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles