dcsimg
www.webdeveloper.com
Results 1 to 3 of 3

Thread: Webpage doesn't structure online, but does offline.

  1. #1
    Join Date
    May 2011
    Posts
    5

    Angry Webpage doesn't structure online, but does offline.

    Hi everyone,

    I wasn't sure what Discussion Board to put this on but thanks in advance.

    I have a HTML webpage written in XHTML 1.0 using CSS.

    I've tried hosting the webpage on both a Windows and Linux CPanl system with the same result and that is the webpage just doesn't structure at all, it's all over the place in Firefox, Chrome, IE 9. But it does look as expected when IE 9 is in compatibility mode or when viewed from IE 8 in normal and compatibility mode.

    However, if I open the .html file locally on my computer the webpages structure perfectly in every browser I throw at it. The only prompt I get is from IE 9 reading 'Internet Explorer restricted this webpage from running scripts or ActiveX controls' then I just click 'Allow Content' and it's fine, I think this is probably just a IE 9 local security setting and nothing to worry about but just thought I'd throw it in encase it gives someone a hint.

    Any help would be greatly appreciated.

  2. #2
    Join Date
    Dec 2003
    Location
    Bucharest, ROMANIA
    Posts
    15,428
    You must have used absolute URL's, not relative. Can we see a link to that page?

  3. #3
    Join Date
    Mar 2012
    Posts
    1

    Fixes That

    This will fix the problem: Go to Tools->Internet Options->Advanced Tab, scroll to the Security section and check 'Allow active content to run in files on My Computer'.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles