All I want to do is the following:

Required PHP Extensions
  1. SOAP
  2. mcrypt
  3. openssl


Required PHP version
  1. 5.2.3 and above


Required PHP Includes
  1. PHP Starter Kit, including:
  2. soap-wsse.php
  3. exacttarget_soap_client.php
  4. exact_soap_client_creator.php
  5. xmlseclibs.php
  6. nusoap.php
  7. parsecsv.lib.phpAll



My server specs are:

Operating system Redhat Enterprise Linux 6
Webmin version 1.580
Kernel and CPU Linux 2.6.32-131.6.1.el6.x86_64 on x86_64


I am still at step one. All I am trying to do right now is:

A) Find out if SOAP is installed in my php
and if so, check if its enabled
and if so, go to step two.

If not, then install it
and enable it.

I have searched my heart out on google and have not found a generic clear cut step by step solution to doing this. First check if soap is there and install it or leave it alone. Thats it.

Please help.

(hint) it helps if a step by step instruction is given. Keep it general.

Thanks guys.