www.webdeveloper.com
Results 1 to 5 of 5

Thread: PHP, Prob a Noob Problem

  1. #1
    Join Date
    Apr 2012
    Location
    Charlotte, NC
    Posts
    2

    Question PHP, Prob a Noob Problem

    For some reason, using Enomcentral.com as my web host I can not get my php forms to mail to my box. I have installed phpmailer_5.2.1 and have edited my php.ini file to include the mailer. Below is my include path in my php.ini.

    ; UNIX: "/path1:/path2"
    ;include_path = ".:/php/includes"
    ;
    ; Windows: "\path1;\path2"
    include_path = ".;c:\php5"
    include_path = "\class.phpmailer.php "

    I try and run a simple php test.


    <?php
    mail('jason@greenwaylawnmanagement.com','Test mail','The mail function is working!');
    echo 'Mail sent!';
    ?>


    It says mail sent yet I recieve nothing in my inbox?? So I thought mb I have to include the path and changed my code to this.


    <?php
    mail('jason@greenwaylawnmanagement.com','Test mail','The mail function is working!');
    echo 'Mail sent!';
    require("class.phpmail.php");
    ?>

    Now this is the error I get....Still no mail in the mailbox.

    Mail sent!PHP Fatal error: require() [function.require]: Failed opening required 'class.phpmail.php' (include_path='\class.phpmailer.php ') in E:\USERS\greenwaylawn\www\phptest.php on line 4



    Is there anything else i need to change in my php.ini file or is there anything i need to change in the phpmailer file... plz help im so lost right now.

    Thank You SOOOOO Much for your time.

  2. #2
    Join Date
    Apr 2012
    Posts
    15
    My question is did you already verified that class.phpmailer.php is there?
    Second where is it? (I mean in what directory)
    Now it seems to me that you are setting the path according to linux rules instead of windows rules, check that, I think you are not modifying the path correctly

  3. #3
    Join Date
    Apr 2012
    Posts
    38
    Seems like you are trying to use this local.
    Is that correct?

    To use the php mail function I believe it's mandatory to have a mail server running. This could cause your trouble.

  4. #4
    Join Date
    Sep 2008
    Posts
    120

  5. #5
    Join Date
    Apr 2012
    Location
    Charlotte, NC
    Posts
    2
    What do you mean by trying to use this local?

    I uploaded my class.phpmailer.php in to the default directory for enom
    ./www

    Anyone have any answers?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles