www.webdeveloper.com
Results 1 to 3 of 3

Thread: Tried to add facebook like button.

  1. #1
    Join Date
    May 2012
    Posts
    1

    Tried to add facebook like button.

    Hi.

    I'm a proper amateur when it comes to this stuff, but I have created a website on a free web editor called Weebly.com. I downloaded this site I made as a zip-file in order to host it elsewhere. Some problems have occurred as a results of this, but I have so far managed to repair these.

    However I have now tried to add a facebook like-button to this site. I followed the explanation here: http://kb.weebly.com/facebook-like.html

    This worked properly in the weebly editor. This is how it appeared there:
    http://i.imgur.com/Hdbdp.jpg


    But this does not work after downloading the site as a zip. Here is how it appear afterwards:
    http://i.imgur.com/AzbEP.jpg

    And the code (after downloading):
    PHP Code:
    <div><div id="784807402536720860" align="center" style="width: 100%; overflow-y: hidden;" class="wcustomhtml"><iframe src="//www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.facebook.com%2FOsloRestaurering&amp;send=false&amp;layout=standard&amp;width=450&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font&amp;height=35" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:35px;" allowTransparency="true"></iframe>></div
    Here is also a screen shot taken of the code:
    http://i.imgur.com/208VM.jpg

    Any got an idea about what's wrong here?


  2. #2
    Join Date
    Feb 2008
    Location
    NW Washington State
    Posts
    1,856
    I'm not sure why you would want to or have to "zip" anything... and I'm afraid to ask!
    Anyway, you have 2 opening <div> tags
    Code:
    <div><div id="784807402536720860"...
    but only one closing <div>.... plus a broken tag
    Code:
    .....</iframe>></div>
    should be:
    Code:
    </iframe></div></div>
    EfV

  3. #3
    Join Date
    May 2011
    Posts
    52
    Also, you are missing the http: at the start of the iframe src.

    HTML Code:
    <iframe src="//www.facebook.com/etc...etc...
    should actually be:

    HTML Code:
    <iframe src="http://www.facebook.com/etc...etc...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles