Page 2 of 2 FirstFirst 12
Results 16 to 26 of 26

Thread: SQLEXPRESS SA default password

  1. #16
    Join Date
    Jan 2007
    I maintain: user error.

    I've certainly never had an issue with it!
    Jon Wire

    thepointless.com | rounded corner generator

    I agree with Apple. Flash is just terrible.

    Use CODE tags!

  2. #17
    Join Date
    Mar 2006
    ok, thanks.

    Please consider the
    environment before printing

  3. #18
    Join Date
    Jun 2012

    Talking Some things to try

    First of all, depends on the way you selected the options.
    As stated previously, if you selected windows authentication then "sa" is disabled. If you have mixed you still might have to enable the "sa" and "sa" can not be blank. There is no default password for "sa", if SQL express comes with a applications ask the applications support team.

    You can put the SQL Server in single user mode and then any member of computer's local administrator can gain access to SQL server as sysadmin.


    Go to SQL Server Properties/Security tab and change the mode to SQL Server authentication mode

    Go to security/logins, open SA login properties

    Uncheck "Enforce password policy" and "Enforce password expiration" check box there if you decide to use weak password

    Assign password to SA user
    If you get "Cannot set a credential for principal 'sa' . (Microsoft SQL Server, Error: 15535)" then "Map To Credential" check box on the General tab of the Login Properties - sa dialog box.

    If “User is not associated with a trusted sql server connection"
    In SQL Server Management Studio, Right-click the Server name, select Properties > Security
    Under Server Authentication, select SQL Server and Windows Authentication Mode
    The server must be stopped and re-started before this will take effect.
    Make sure the sa (at status tab of sa properties) is enabled after restart the server.

    -Matt Stone

  4. #19
    Join Date
    Mar 2006
    as I stated before- any attempt to change anything in SQL property end up same way - user not authorize to perform this action.
    I going to reinstall entire package one more time (already did this 3 times) to see if I missed anything where I can setup password for SA or any user at all for database.
    And if it is not there I am going to report this as a bug to Microsoft on MSDN.

    Please consider the
    environment before printing

  5. #20
    Join Date
    Jan 2007
    I'd be interested to know what particular package is giving you so much trouble.
    Jon Wire

    thepointless.com | rounded corner generator

    I agree with Apple. Flash is just terrible.

    Use CODE tags!

  6. #21
    Join Date
    Sep 2012


    Alexsts, did you find a solution to this? I've experienced the same problem for the last month when trying multiple times to install DotNetNuke. It downloaded SQLExpress as part of the installation, then asks me for the password which I've not given. If you found the solution, please share. Thanks.

  7. #22
    Join Date
    Jun 2012

    Again, read my post on 6/8

    I explained how to gain access using single user mode or at least point you to the resources. Since this is part of installing a package you should talk with their support because they configure the user accounts. If you do get in with Single user mode, my post also points out where to look to make sure "sa" is configured, correctly. Althought your probably better off creating a new account as the "sa" user might be tied to the application and changing anything could break the app. Some SQL 2005 include the local admin's as a SQL Administrator so that is one thing to always try. You can also try logging in as the service account that is commonly used as a SQL Administrator assuming not local system or network service .

    Just a FYI...
    Now if you are having issues connecting you might have to do some digging to find out what the instance name and port settings are. I had one a month ago that was using Named Pipes which has a funky connection string. Took me a few hours to break in but once I relized it was named pipes took me a few minutes LoL.

  8. #23
    Join Date
    Sep 2012
    I don't know if this will help, but I also was not asked to set a user and when I opened management studio was just connected. But, when I went to add a database my login was denied. I exited management studio and restarted it by right clicking and doing the run as administrator option. I retried creating the database and it then worked.

  9. #24
    Join Date
    Sep 2012


    I ended up resolving the issue about an hour after my last post. Although I'd previously uninstalled all SQL programs/modules and tried reinstalling, I did it one more time and then attempted to reinstall DotNetNuke (which is what needed SQL Express and had been trying to install it as part of the DNN installation) and it installed perfectly.

  10. #25
    Join Date
    Oct 2012
    Sometimes when you install SQL Express 2005, a component of another product, that will install the application to configure the environment, and reduce the effectiveness of your access to the SQL database. This is primarily due to the application set the SA password and not tell you what it is.

  11. #26
    Join Date
    Jun 2013
    Quote Originally Posted by alexsts View Post
    Once again should off, would off, could off but in reality is not.
    Thanks for your time and efforts.
    See you in cyberspace.
    yes, it is sometimes difficult to argue with MS die hard defenders. for anyone who arrives to these pages....

    i do not think there is a default SA password. if you do not get an option to specify it during the install, it is probably set to "undefined" or something like that.

    your most promising option is to install SQL Server Management Studio and change the SA password when the application custom installer prompts for it.

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center



X vBulletin 4.2.2 Debug Information

  • Page Generation 0.14696 seconds
  • Memory Usage 2,960KB
  • Queries Executed 15 (?)
More Information
Template Usage (36):
  • (1)ad_footer_end
  • (1)ad_footer_start
  • (1)ad_global_above_footer
  • (1)ad_global_below_navbar
  • (1)ad_global_header1
  • (1)ad_global_header2
  • (1)ad_navbar_below
  • (1)ad_showthread_firstpost_sig
  • (1)ad_showthread_firstpost_start
  • (1)ad_thread_first_post_content
  • (1)ad_thread_last_post_content
  • (1)bbcode_quote
  • (1)footer
  • (1)forumjump
  • (1)forumrules
  • (1)gobutton
  • (1)header
  • (1)headinclude
  • (1)headinclude_bottom
  • (11)memberaction_dropdown
  • (1)navbar
  • (4)navbar_link
  • (1)navbar_moderation
  • (1)navbar_noticebit
  • (1)navbar_tabs
  • (2)option
  • (1)pagenav
  • (1)pagenav_curpage
  • (1)pagenav_pagelink
  • (11)postbit
  • (11)postbit_onlinestatus
  • (11)postbit_wrapper
  • (1)spacer_close
  • (1)spacer_open
  • (1)tagbit_wrapper 

Phrase Groups Available (6):
  • global
  • inlinemod
  • postbit
  • posting
  • reputationlevel
  • showthread
Included Files (26):
  • ./showthread.php
  • ./global.php
  • ./includes/class_bootstrap.php
  • ./includes/init.php
  • ./includes/class_core.php
  • ./includes/config.php
  • ./includes/functions.php
  • ./includes/functions_navigation.php
  • ./includes/class_friendly_url.php
  • ./includes/class_hook.php
  • ./includes/class_bootstrap_framework.php
  • ./vb/vb.php
  • ./vb/phrase.php
  • ./includes/functions_facebook.php
  • ./includes/functions_calendar.php
  • ./includes/functions_bigthree.php
  • ./includes/class_postbit.php
  • ./includes/class_bbcode.php
  • ./includes/functions_reputation.php
  • ./includes/functions_notice.php
  • ./packages/vbattach/attach.php
  • ./vb/types.php
  • ./vb/cache.php
  • ./vb/cache/db.php
  • ./vb/cache/observer/db.php
  • ./vb/cache/observer.php 

Hooks Called (74):
  • init_startup
  • friendlyurl_resolve_class
  • init_startup_session_setup_start
  • database_pre_fetch_array
  • database_post_fetch_array
  • init_startup_session_setup_complete
  • global_bootstrap_init_start
  • global_bootstrap_init_complete
  • cache_permissions
  • fetch_postinfo_query
  • fetch_postinfo
  • fetch_threadinfo_query
  • fetch_threadinfo
  • fetch_foruminfo
  • load_show_variables
  • load_forum_show_variables
  • global_state_check
  • global_bootstrap_complete
  • global_start
  • style_fetch
  • global_setup_complete
  • showthread_start
  • showthread_getinfo
  • strip_bbcode
  • friendlyurl_clean_fragment
  • friendlyurl_geturl
  • forumjump
  • cache_templates
  • cache_templates_process
  • template_register_var
  • template_render_output
  • fetch_template_start
  • fetch_template_complete
  • parse_templates
  • fetch_musername
  • notices_check_start
  • notices_noticebit
  • process_templates_complete
  • friendlyurl_redirect_canonical
  • showthread_post_start
  • showthread_query_postids
  • showthread_query
  • bbcode_fetch_tags
  • bbcode_create
  • showthread_postbit_create
  • postbit_factory
  • postbit_display_start
  • bbcode_parse_start
  • postbit_imicons
  • bbcode_parse_complete_precache
  • bbcode_parse_complete
  • postbit_display_complete
  • memberaction_dropdown
  • pagenav_page
  • pagenav_complete
  • tag_fetchbit_complete
  • forumrules
  • navbits
  • navbits_complete
  • build_navigation_data
  • build_navigation_array
  • check_navigation_permission
  • process_navigation_links_start
  • process_navigation_links_complete
  • set_navigation_menu_element
  • build_navigation_menudata
  • build_navigation_listdata
  • build_navigation_list
  • set_navigation_tab_main
  • set_navigation_tab_fallback
  • navigation_tab_complete
  • fb_like_button
  • showthread_complete
  • page_templates