www.webdeveloper.com
Results 1 to 3 of 3

Thread: Debugging help in IE8

Hybrid View

  1. #1
    Join Date
    May 2012
    Posts
    9

    Debugging help in IE8

    The site in question works great on every browser except IE8. There is a div underneath the blue logo on the left hand side of the page that fades in with some copy. It is driven by a simple embedded script. However, I cannot figure out why it is not working in IE8. It just will not show up. I have tried multiple things and at this point I dont care if the fade in works, I just want the side text to appear on the left hand side of the page underneath the logo without having to reformat the page. I tried removing the javascript altogether and and removing the "Display: none" funtion from each div so they would be visible, but they are still not showing up. What gives?

    The div that it being called by the javascript code is #wrapper_content_home, by which it contains three other divs within it that fade-in when the script id fired (#pageTitle, #solidDivider, #sideContent).

    I am currently using VirtualBox to test and have it configured to Windows XP 32 bit using IE8.

    Can anyone tell me what's wrong with my code or what I need to do to fix this issue? Could it be a Doctype declaration issue? At this point, I have no idea. Thanks in advance for any help with this!

    Here is a link to the page in question: http://fountainplace.com/team/

    Here is a JS Fiddle I set up for debugging (view my code): http://jsfiddle.net/FAzaD/2/

  2. #2
    Join Date
    May 2012
    Posts
    9
    Anyone?

  3. #3
    Join Date
    Dec 2011
    Location
    Centurion, South Africa
    Posts
    795
    At first glance I see a big problem:

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head profile="http://www.w3.org/2005/10/profile">
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
    <title>Fountain Place | Property Management</title>
    
    <link rel="stylesheet" media="screen" type="text/css" href="css/team.css" />
    <link rel="stylesheet" media="print" type="text/css" href="css/print.css" />
    <link rel="shortcut icon" type="image/x-icon" href="../favicon.ico" />
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
    <head>
    
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script>
    
    <script type="text/javascript">
    
    ...
    You have multiple <html>, <head> and possibly other tags that would break things.
    Run your site through a validator to find other errors: http://validator.w3.org/
    Last edited by bionoid; 08-17-2012 at 01:11 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles