www.webdeveloper.com
Results 1 to 4 of 4

Thread: <a> Tag Not Working in Opera/Firefox z-index problem

  1. #1
    Join Date
    Jul 2012
    Posts
    32

    Question <a> Tag Not Working in Opera/Firefox z-index problem

    okay So I Have A Few Websites That Use Div Wrappers so I Can Have "Fixed" Content In IE, Well in That "Fixed" Content I Have Links, EveryThing Works Fine In Internet Explorer (For Once), But Not In Opera, Or Firefox, I Just Narrowed it Down To The z-index, here is Some Code,,,
    Code:
    			#Fixed{
    				position: Fixed;
    				_position: Absolute;
    				background-color: black;
    				top: 50&#37;;
    				bottom: 50%;
    				width: 200px;
    				height: 100px;
    				z-index: 0;
    				}
    			#Wrapper{
    				position: relative;
    				border: 0px;
    				margin: 0px;
                                                 padding: 0px;
    				max-height: 100%;
    				overflow: auto;
    				color: white;
    				z-index: 1;
    				}
    if i move the fixed up it will work, how can i make it work when it is in the other z-index? Thanks For Any/All Help...

  2. #2
    Join Date
    Feb 2005
    Location
    Tauranga
    Posts
    2,062
    you know this is a PHP Forum right ?

    also, your fixed div needs a higher z-index.

  3. #3
    Join Date
    Jul 2012
    Posts
    32
    Sorry, I Did Not See it Was In PHP, Okay Thanks

  4. #4
    Join Date
    Jul 2012
    Posts
    32
    changing the z-index doesn't help, because i need it to hide under the table if the width is to small

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles