www.webdeveloper.com
Results 1 to 6 of 6

Thread: Jquery not firing right in IE7/ CarouFredSel

  1. #1
    Join Date
    Sep 2008
    Posts
    20

    Jquery not firing right in IE7/ CarouFredSel

    Hello,
    I have implemented carouFredSel (with the basic example with next/prev and pagination) into Chrome, Firefox, IE9 and 8. For some reason though when viewing IE7 it seems to me that the plugin does not fire right. It just shows the list going down and does not put it into oveflow hidden or a line where the next and previous buttons will work. Is there something I am missing here?

    I have looked through installation several times and also tried to implement this on IE7 on a standalone page and was unable to. As well, I have looked thorugh the configuration and custom events and ie7 developer toolbar. It seems that the plugin is just not setting up the correct things on IE7 as it does create the class/id's foo2 and image_carousel.

    Thank you for your time.
    Kamron

    http://www.kamsshowcase.com/stws-wp/?page_id=114 is the website I am working on.

  2. #2
    Join Date
    Nov 2010
    Posts
    1,086
    IE is very picky about "dangling" commas - if you leave one at the end of a list, it will think there is something after it but gets confused when it doesn't find anything (thus causing the famous "Expected identifier, string or number" error). I'm surprised your site works in IE8... but anyway. If you change this:
    Code:
    email: {
                            required: true,
                            email: true
                        },
                    },
                    messages: {
    to this:
    Code:
    email: {
                            required: true,
                            email: true
                        }
                    },
                    messages: {
    it should work everywhere
    Last edited by xelawho; 09-15-2012 at 07:46 PM.

  3. #3
    Join Date
    Sep 2008
    Posts
    20
    Hello,
    Thank you so much for your response. I am heading out now but I will try it shortly. I had looked for trailing commas but I must have missed it :-/.

    I do have a question though. When you mentioned surprised my site works in IE8 did you mean the Jquery itself or parts of the CSS/HTML. I assume the JQuery but I wanted to make sure as I am trying to get better at coding so I figured I would clarify.

    Thanks again!

  4. #4
    Join Date
    Nov 2010
    Posts
    1,086
    no, I was just surprised that IE8 had relaxed on the trailing commas. I don't remember that being the case but it seems to be so (on my version, anyway). They're a good thing to avoid, anyway, regardless of if you can get away wit it.

  5. #5
    Join Date
    Sep 2008
    Posts
    20
    Okay. Yup that trailing comma worked like a charm. Once fixed the validation worked correctly and so did the CarouFredSel. I am frustrated I missed it actually haha.

    Thank you again for your help.

  6. #6
    Join Date
    Nov 2010
    Posts
    1,086
    glad you got it working. In a rare episode of helpfulness, IE was actually reporting a vaguely meaningful error message here, on a line that was actually pretty close to where the error was occurring

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles