www.webdeveloper.com
Results 1 to 4 of 4

Thread: Transparency - disappearing colours

  1. #1
    Join Date
    Jan 2003
    Posts
    2

    Cool Transparency - disappearing colours

    I'm working on my first website and have had problems with my transparent GIFs.

    I've created them using ULead Photoimpact and also Paintshop Pro 5, but have met the same problem each time.

    When I use the transparent GIF in a web page, and open the page in IE5 or Neoplanet 5.2, the background is transparent (hurray - this is what I wanted) but the coloured logo is black. If I go to another page on this site (which uses a version of the logo that is not a transparent gif), then when I use the "Back" button to get back to the original page, the logo is magically coloured. Help! Why is this happening? The logo is coloured when the same page is viewed using Netscape 6 & Netscape 7.

    When I created the GIFs, I made sure they had less than 256 colours (they had 16 colours). I filled the background with the same colour as the background colour of the menu bar in which the GIFs appear. I made this colour transparent and I saved the GIFs as non-interlaced GIF89a.

    Any help for this graphics novice would be greatly appreciated!

    Nicky M

  2. #2
    Join Date
    Dec 2002
    Location
    Australia
    Posts
    39
    well i don't know too much about either graphics program but i have made transparent gifs in psp5.

    -Fill the transparent background with a color.
    -Select COLORS...SET PALETTE TANSPARENCY (Ctrl+Shift+V).
    -Click "YES".
    -Click "OK".
    -Select "Set the transparency value to pallette entry" then click the color you want to be replaced by transparency.
    -Click "PROOF" (the transparency should now be proved on the image)
    -Click "OK"

  3. #3
    Join Date
    Jan 2003
    Posts
    2

    Unhappy

    Thanks very much for the tips on using PSP5. I tried this and unfortunately it didn't make any difference - the transparent GIF still loads with transparent background and black drawing.

    Nicky M

  4. #4
    Join Date
    Dec 2002
    Location
    Lake Havasu City, Arizona
    Posts
    527
    The logo is coloured when the same page is viewed
    What you may be seeing is what was in cache. Don't hit the back button, instead open up the page again. I bet you the logo is not magically colored

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles