www.webdeveloper.com
Results 1 to 4 of 4

Thread: Alternative to XMLHTTPRequest

Hybrid View

  1. #1
    Join Date
    Apr 2012
    Posts
    11

    Question Alternative to XMLHTTPRequest

    Hello!

    I have a problem with the XMLHTTPRequest object.

    On the original webserver is a data server running where I can request data by the 'post' command.
    Because this data server is running local on the original webserver it will work because it is the same domain.
    So I can access the webserver with the data from outside of my network.

    But this original webserver is really shi*%. It is slowly and have problems with pictures and and and...

    So I installed a additional webserver on my router. But now I have a XMLHTTPRequest with cross domain.
    So I can't get it working with all web browser.

    I can't change anything on the original webserver because it is a embedded server.
    I can't enable cross domain on the original webserver.


    Is there a way to handle the http request step by step without using the XMLHTTPRequest object?
    I want to send a XML-String to the data server and the response would be also a XML-string.

    May by jQuery?

    Somebody please help!

  2. #2
    Join Date
    Jan 2007
    Location
    Wisconsin
    Posts
    2,120
    Either use your new server as a proxy to the old server or run your POSTs via an iframe.

  3. #3
    Join Date
    Apr 2012
    Posts
    11
    thx!

    May you can help some more about proxy.

    I use lighttpd for the new server.
    This server has a proxy module.

    EDIT:
    I love you!!

    It took me a few weeks working and testing with the cross domain feature.
    Now I enabled the proxy in lighttpd and it is working without problems!!

    Code:
    $HTTP["host"] =~ "192.168.0.1" {
    
        $HTTP["url"] =~ "^/cgi-bin(.*)$" {
            proxy.server  = ("" => (
                ("host" => "192.168.0.20", "port" => 80)
            ))
        }
    }
    Last edited by schwa226; 10-22-2012 at 02:22 PM.

  4. #4
    Join Date
    Jan 2007
    Location
    Wisconsin
    Posts
    2,120
    Awesome! Glad you got it working.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles