dcsimg
www.webdeveloper.com
Results 1 to 4 of 4

Thread: process page issues

  1. #1
    Join Date
    Feb 2009
    Posts
    18

    process page issues

    hi guys am developing a portal which has a registration form...
    what happens is this, when the dropdown that is labeled state is selected another dropdown and text box is made visible, but the data from the state dropdown, LGA dropdown and unit textbox isnt submitting the data into my db...

    i even tried echoing them out on in the process page but it doesnt work...
    here is the script. am hoping someone would come to my aid on this thanks



    Thanks dominic
    Attached Files Attached Files

  2. #2
    Join Date
    May 2003
    Posts
    599
    In your "register.txt", in your form you have multiple "<input type="unit" id="unit" name="unit" ..... placeholder="unit" required />" inputs.

    First: "unit" is not a valid value for the "type" attribute of an input...( see: http://www.w3schools.com/tags/att_input_type.asp )

    Second: All form inputs must have a unique "name" attribute ( the first unit input might have a value, but the second one which may have none will overwrite it in the POST processing variables).

    Third: You have the same thing going on with your select boxes sharing the same "name" values.

    I did not look into your processing script since these issues might explain why you are getting blank values when echoing them. After you get the form cleaned up with unique inputs then we can look at the processing if necessary.

  3. #3
    Join Date
    Feb 2009
    Posts
    18
    ok thank let me do this and see if it would work

    would send a message when am done

  4. #4
    Join Date
    Feb 2009
    Posts
    18
    register2.txtprocess2.txtregister2.txtprocess2.txthey i did exactly what you asked me to do, it echoed on the process page alright..

    i even went as far as creating an array for it, cause i want it to post into the db but i can seem to post it.. i want when a user selects a state and the dropdown for LGA and unit is made visible, when he select the right LGA and types in his unit, its been sent into the db, cause the table in my db just has one column for LGA same as unit...


    here are the modified scripts

    thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles