www.webdeveloper.com
Results 1 to 4 of 4

Thread: Scripts NOT WORKING on GOOGLE domains?

  1. #1
    Join Date
    Dec 2012
    Posts
    3

    Scripts NOT WORKING on GOOGLE domains?

    Hello,

    As many of you might know in modern browsers there is support for "User Scripts". In Opera for example Opera --> Settings --> Preferences --> Advanced --> Content --> JavaScript Options


    In other words, you can write your own javascripts, save it locally and add it to sites you open from the web.

    What I want is to bypass those click-tracking redirects in the Google search results and found literally tons of scripts on userscripts.org that claim to serve that purpose. However, none of these actually work in Opera browser. After experimenting for about an hour I found that actually even the most simple script isn't working on google.com domains!

    For example, this simple script brings up the alert box on yahoo.com, facebook.com, digg.com... etc but does not work on google.com

    PHP Code:
    (function () 

    alert('Testing success!'); 
    })(); 
    So once again, in Opera --> Settings --> Preferences --> Advanced --> Content --> JavaScript Options I set the "User Script" folder and in that folder there there are my .js files working whichever domain I open except google.com

    Anybody knows what's going on here?

  2. #2
    Join Date
    Aug 2008
    Location
    Sweden
    Posts
    227
    It sounds like it should work. Is JavaScript on for google.com? Did you specify that the script should execute for google.com? Any misspellings? Maybe you're redirected from http:// to https:// or something and that messes thing up?
    New to web development or in need of a good reference? Check out the Mozilla Developer Network or W3Schools.

  3. #3
    Join Date
    Dec 2012
    Posts
    3
    Quote Originally Posted by refreezed View Post
    It sounds like it should work. Is JavaScript on for google.com? Did you specify that the script should execute for google.com? Any misspellings? Maybe you're redirected from http:// to https:// or something and that messes thing up?
    Nope, nothing! The javascript works on google because as I type it brings up suggestions. Anyone can reproduce this?

  4. #4
    Join Date
    Dec 2012
    Posts
    3
    Ok got it!

    In Opera --> Settings --> Preferences --> Advanced --> Content --> Manage Site Preferences I had google.com and few other domains listed though I DID NOT add them there.

    Anyway, I removed them all and now I't working!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles