www.webdeveloper.com
Results 1 to 4 of 4

Thread: My site is remembering and adding the last path to links - help needed please

  1. #1
    Join Date
    Jan 2013
    Posts
    2

    My site is remembering and adding the last path to links - help needed please

    Hi all, I am after the use of some more experienced brains than mine.

    My website has started experiencing the following issue.

    My site is www.lindenbleijie.com.au, that part is working fine. From there I have a series of pages e.g. about me, landscape, home etc. It has been working fine for years. My directory tree is as follows - lindenbleijie.com.au/pages/.....whichever page you click. Then on each of those pages it has the same menu for links back and around the site.

    All of a sudden it is now adding the last pages path to the link. e.g If I go directly to the site www.lindenbleijie.com.au/index.html then hover or click on the "Contact me" link (as an example) it says http://www.lindenbleijie.com.au/Page...tactindex.html and it works fine. Then the issue comes up. If I now hover or click on a link, e.g. 'home', it now says www.lindenbleijie.com.au/Pages/contactus/index.html. The bold section should not be there. It is like it is remembering the last path and adding it before going the the correct index at the end, of course, as that path and index doesn't exist it comes up with a 404, you will see what I mean on the site. I have checked the link code in dreamweaver and it is still correct and have tried searching the net and this forum but not sure if I nailed the terms to get a result as I haven't found any info. .

    Hopefully someone here can help.

    If this is in the wrong section can the mods please move.

    Thanks.

    Linden

  2. #2
    Join Date
    Aug 2006
    Posts
    1,908
    The links on those pages in the menu should all start with a "/". Right now for example, some start with "Pages..." which means "start where you are now, and look for a subdirectory named Pages, and go down from there". With the slash in front, it means "Start at the top of my directory, and look for a subdirectory named Pages".

    Dave

  3. #3
    Join Date
    Jan 2013
    Posts
    2
    Thanks tracknut,

    I just went through and fixed them all up, I made the page in dreamweaver and did the little target icon thing for the links and it all worked fine. Do you have any ideas on why it would have changed? I cannot say for sure whether dreamweaver put the / in there initially.

    Anyway thanks again so much for your help.

    Linden

  4. #4
    Join Date
    Aug 2006
    Posts
    1,908
    I have never used Dreamweaver, but can imagine it wouldn't be fun if my editor just "decided" to start editing my code on its own

    Dave

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles