I'm trying to add a .dll. This .dll was part of the project already, but today it started not working. I've tried re-adding it, and even re-adding different versions of it clear back from 2009, I keep getting the same error.

Here is the error:
The primary reference "myDLL" could not be resolved because it has an indirect dependency on the framework assembly "System.Core, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" which could not be resolved in the currently targeted framework. ".NETFramework,Version=v2.0". To resolve this problem, either remove the reference "myDLL" or retarget your application to a framework version which contains "System.Core, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089".

The project is in .NET 2.0, upgrading it to 3.5 or 4.0 is not an option.

The current version of the myDLL, which is the one that is also GAC'd, is compiled as 3.5, but (a) it has worked up until today and (b) even the older 2.0 versions I've pulled in still give this error.

One of my co-workers can open the project and add the .dll just fine.

I'm using VS2010.

I also tried rolling back the project to the last entry in our source control, same error.